Lenovo ThinkPad T480

The HCL Support Files may contain numerous hardware details, including serial numbers. If, for privacy or security reasons, you do not wish to make this information public, please do not post the .cpio.gz file on a public mailing list or forum.

Also: the cpio file is only really helpful or needed in combination with an actual qubes-issues investigation, so as a standard contribution to the HCL the yml file is sufficient. Thank you for reporting!

Thank you @aronowski for your report, which is online now!

  • you didn’t indicate whether everything works, but since we already have several positive T480 reports I am assuming yours is positive too – please speak up if that’s mistaken
  • I moved your report along with @SoPunny’s into this original thread by @den1ed in an effort to have all reports for a particular make/model in one thread (easier to find and consume for other forum users)

for my daily usage I cannot see anything wrong with it apart from one annoyance - when I have my cursor located somewhere in the bottom of the screen, the display glitches out and starts flickering. Though this might not be a Qubes issue at all - should double check with another Live system.

I haven’t tested Bluetooth, fingerprint scanner, or the smart card reader, but everything else seems to work.

Sometimes it takes the system a long time (~30sec) to return from suspend. I did 10 suspend testes before uploading the hcl and one of them took a long time, but the system did wake up.

brand: |
model: |
bios: |
N24ET70W (1.45 )
cpu: |
Intel(R) Core™ i5-8250U CPU @ 1.60GHz
cpu-short: |
chipset: |
Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:5914] (rev 08)
chipset-short: |
gpu: |
Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA controller])
gpu-short: |
network: |
Intel Corporation Ethernet Connection (4) I219-V (rev 21)
Intel Corporation Wireless 8265 / 8275 (rev 78)
memory: |
scsi: |

usb: |

  • works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    credit: |
    link: |

Qubes-HCL-LENOVO-20L60034MX-20221024-165644.cpiogz (10.1 KB)

1 Like

Are you still experiencing issues with suspend?

Would it make sense to investigate if the T480 could be added to the community list?

Has anyone experienced any issues with this model?

I have had one for 2 weeks, and my experience seems inline with that of other users, everything just seems to work.

I think the main reason for adding it to the list is the low price point, I bought mine from a Lenovo certified reseller and a used model (grade c) cost me $225 before sales tax, upgraded with 32 GB memory and 500 GB NVMe and the total price was around $400.

ME_cleaner seems to work with the stock firmware, but cleaning the firmware adds a 30 sec delay when booting the system, HAP disable (without cleaning) doesn’t add the delay.

I have not had a chance to test the thunderbolt dock yet.

1 Like

Thank you for the ping. The criteria are:

  • Qubes OS installs without any workarounds
  • Graphics, networking, audio & suspend work without troubleshooting
  • Recommended 16 GB RAM 52 are possible
  • Keyboard can be connected via PS/2 in case of desktops
  • Readily available to be purchased (including pre-owned)
  • Multiple community members have confirmed the above (machines that were included in a previous release version of this list need only one good report to be re-included)

Also the list is structured in a make/model/CPU way. So let’s have a look:

  • i7-8650U reported twice, once for R4.1 and once for R4.0, both positive, but mentions having to detach the second USB controller from sys-usb for suspend to work
  • i7-8850U reported by one user positively for both R4.0 and R4.1
  • i5-8250U reported once for R4.1 as partial because of suspend issues
  • i5-8350U reported twice for R4.0, one of them as partial and reporting various issues / workarounds.

R4.0 is EOL so the only reason I mention it here is that if I had overlooked a valid case for inclusion in the R4.0 list this could count to weaken the two reports requirement for the R4.1 list.

We only have one R4.1 report not mentioning any issues / workaround. But we also do not have any R4.1 report for the T480 from you :wink: … so why don’t we start there: please submit a report and let’s see how that changes the above summary.

That sound great, can you point me to those “other users” / their posts for further investigation?

1 Like

I’ll submit an HCL report when I get home from work.

I was reading this thread

It’s true that it takes 20-30 sec to return from suspend, but I also have a T490 running Windows 11 and it also takes the T490 a long time to return from sleep, I’ve not had to reset sys-net or sys-usb.

Maybe it would make sense to make a thread just to compare experiences with the model, me saying it works doesn’t do anyone any good if I’m the minority.

1 Like

That’s what the thread you linked is for. Also, these reports are snapshots over time. It is entirely conceivable that with the latest R4.1 install media the T480 is ready to go on the “just works” list.

Next steps:

  1. get your HCL report and see what CPU your T480 has
  2. identify other community members who have the same model/CPU
  3. ask them how their experience with R4.1 install was / if the criteria are fulfilled

Thank you @renehoj for your report, which is online now!

I have moved our posts into this thread. So you are using the i5-8250U like @SoPunny.

I think we are close if we can clarify whether there are suspend issues or not. What’s the difference between “Deep Suspend” and “Idle Suspend”? Has anything changed in the last few weeks – @SoPunny?

I’ve spent most of the evening testing the suspend function, and I can’t reproduce the situation where it takes a long time to wake up.

Reconfiguring the thunderbolt port can result in pci devices being added/removed, which means you manually need to update the sys-usb device list.

Enabling hyper-threading adds a 5-10 sec delay on waking up the system, but it doesn’t add the really long delay. This seems similar to how suspend works on my Windows system.

With sys-usb/thunderbolt correctly configured and hyper-threading disabled, it takes ~2 sec to wake up the system.

Sadly, I didn’t check the logs when I experienced the slow wake-up, I think some software/OS error happened during the wake-up, and the long delay is a software timeout.

Tomorrow I’ll try and get a dock and see if using the thunderbolt port makes suspend fail.

For the community recommended list it is critical that a PC works “out of the box” using just the installer and no other instructions or workarounds. Would you say that’s the case with your T480?

I haven’t found any bios settings that prevent you from using Qubes, but I need a dock to test if the thunderbolt port actually works, hopefully I can do this today.

I tried reinstalling Qubes with a couple different Thunderbolt settings, and they all worked “out of the box” with sys-usb being created during installation.

If after installing Qubes you go into the bios and change the thunderbolt configuration, it reconfigures the pci devices and this can result in an unknown or missing device in the sys-usb device list. I assume this is considered outside the standard installation.

The dock worked with default settings, I have not been able to find anything that doesn’t work out of the box.


That’s great! … @SoPunny can you confirm?

Upgraded my motherboard from the i5-8250U to the i7-8650U

The only difference I’ve found is that the i7 is vPro with AMT, apart from that the i5 and i7 are identical.

Everything works.

Qubes-HCL-LENOVO-20L6S1LV0A-20221119-213031.yml (859 Bytes)

Qubes-HCL-LENOVO-20L6S1LV0A-20221119-213031.cpiogz (10.7 KB)


Thank you @renehoj for your updated report, which is online now!

@aronowski can you confirm that the i7-8650U works out-of-the-box?


As I said earlier, everything seems to work fine and I only get visual glitches by having my cursor at certain height.
Maybe there’s something more precise I could test out. Tell me more if that’s the case.

I do, however, see an older entry:

I haven’t tested Bluetooth

It does work - check this out.

Idle suspend works as intended when I just shut my laptop. I wait for about 10 seconds to be able to enter my password. I’m using it with i3, and I think i3-settings-qubes comes with xss-lock. I think. It doesn’t show any password characters but a circle that turns green whenever I press a key.

When I enter cat /sys/power/state, I get freeze mem. Freeze means suspend-to-idle and mem means suspend-to-memory.

The freeze option, when set, will initiate a lightweight software-based-only sleep state for your system. The Linux user space will be frozen (hence the term) and all I/O devices will be put into a low power state. Whilst this option and state is always supported, and does limit energy uses, it is the most light form of halting your machine. If no other options are available to you, this may still save on the electricity bills, though not as much as shutting down the system.

The mem option, when set, will initiate either a Suspend-To-Idle, which is identical to the freeze option, or do a Suspend-To-RAM, where it everything in the system is put into a low-power state except for the memory. Which option is used (Suspend-To-Idle or Suspend-To-RAM) depends on the setting of the /sys/power/mem_sleep file. You can examine the various modes of this file by simply executing cat /sys/power/mem_sleep at the terminal command line.

Source: https://www.howtogeek.com/devops/how-to-hibernate-or-sleep-linux-from-the-command-line/

No comment on suspend-to-ram. I never use it.