Lenovo Thinkpad P14s AMD Gen2 worth trying?

In need for a new laptop I found the Lenovo Thinkpad P14s AMD Gen2. I know, very new (Ryzen 5850U, Zen 3), but will qubes work? I would like to keep qubes as OS …

Is qubes supporting UHD-displays including scaling? Or better stay with FHD?

I don’t know about that hardware specifically, maybe check the HCL. I have a Ryzen 4700U AMD machine and it works well with Qubes 4.1 (not tried it on any other version). IOMMU works on this machine, although my graphics, audio, usb and bluetooth are on the same bus, so I think aren’t isolated. But I’ve had no real problems. It’s a shame heads/coreboot aren’t a possibility either but it’s the price you pay for new hardware.

If you don’t mind less stability, I’d recommend installing one of Fepitre’s weekly build ISOs. Otherwise you may have problems installing. You’d at least need up-to-date linux-firmware and a recent kernel.

It would be unfortunate though if you plumped for it and couldn’t get Qubes going, so I guess that’s the crux of it. Do you want to roll the dice?

I don’t think UHD is an issue. You can scale XFCE in dom0 to 2x and set GDK and QT scaling. Or you could install KDE and have more flexibility.

I have the P14s AMD Gen2 currently here. Qubes R4.1 Beta installs out of the box. It works and seems usable, but Wifi (Realtek 8852AE) and resume from suspend dont work.
Resume at least lets appear the unlock screen before screen freezes/turns black and writes some logs (amdgpu, gfx ring stuff, maybe grafics?), but had no time to dig deeper.
Brightness Control (FN) works with Kernel 5.10.60 (current-testing).
Kernel 5.13.* (= Fepitres kernel-latest builds) reboot (loop) immediately before anything appears on screen.

I will try to get amdgpu and wifi drivers running, maybe that solves resume problems too.

1 Like

For the 8852AE I think you will need to build drivers -
GitHub - lwfinger/rtw89: Driver for Realtek 8852AE, an 802.11ax device is source

Thx, found that already, but how do I get that into dom0? I cant use git directly.

Ups, not enough coffee -_- Thx, got it (thru zip/unzip) … but still no wifi nor pci device in list. Any suggestions?

Devices on Qubes are isolated from dom0 for good reasons.

Upd: networking is handled by sys-net qube. To install something in it, you need to go to its TemplateVM. By the way, I can’t even find any description of the default qubes in the docs. @adw did I miss it?

Thats what I … ahm … now I’m insecure if I installed it in appvm or template -_-
As it didnt work I thought dom0 needs the driver to too.

Sorry about that, I thought you were talking about a different driver needed for dom0. As the security notice in my link says, you should always double-check all software you’re installing in dom0 (and do it as rarely as possible). If you checked it, you should probably be fine (or, you can always backup your qubes and restore them on a new, perfectly secure, system).

If the driver in sys-net does not work, you should probably start a new topic, so the community can help you.

I’ll give it tomorrow a second try. I guess the fact lspci didnt show wifi device in dom0 confused me, but thats “normal”, right? Or does that mean theres some bigger problem?

Yes, it’s by design. There should be no WiFi device in dom0. It should be connected to sys-usb, which is reflected in its preferences.

4 posts were split to a new topic: Description of default qubes for beginners

I opened a separate thread regarding WiFi / RTL8852AE, see Problems with RTL8852AE (rtw89)

Current status, beside WiFi and resume (from suspend) the P14s AMD Gen2 just works. When I get the actual device (the current gets replaced) i’ll post a HCL.

1 Like