Lenovo ThinkPad P1 (Gen4)


I couldn’t upload the HCL, so I’ve put it below:

brand: |
model: |
bios: |
  N40ET29W (1.11 )
cpu: |
  11th Gen Intel(R) Core(TM) i7-11850H @ 2.50GHz
cpu-short: |
chipset: |
  Intel Corporation 11th Gen Core Processor Host Bridge/DRAM Registers [8086:9a36] (rev 05)
chipset-short: |
gpu: |
  Intel Corporation TigerLake-H GT1 [UHD Graphics] [8086:9a60] (rev 01) (prog-if 00 [VGA controller])
gpu-short: |
network: |
  Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz (rev 1a)
memory: |
scsi: |

usb: |

- works:
  qubes: |
  xen: |
  kernel: |
  remark: |
  credit: |
  link: |


Recently purchased a Lenovo Thinkpad P1 (Gen4) after much research and internal debate. Based on my research, I specifically hunted out the model with no dGPU and only the Intel iGPU. That way all my video outputs such via HDMI and ThunderBolt (DP AltMode via USB-C) are pinned to the iGPU and I don’t have to mess around with nVidia or AMD crap in Dom0, I get better battery life and it’s just less of a pain in the ass when running Qubes or any *nix based distribution.

I should mention that at present I’m using the P1 with a Dell WD19TB dock (and 4 x monitors) and it’s working quite well for the most part in terms of video outputs and downstream USB. Based on another member’s thread on the forums, I actually created an additional sys-usb-dock DispVM to which I’ve assigned the dock’s USB controller to. Note that I’m just using the Dell dock at the moment as it’s all I’ve got. It’s not the best option as it doesn’t provide enough juice to properly charge the P1. The Lenovo Thunderbolt 4 Workstation (not Universal) appears to be the better choice if you’re considering a new one.

Overall I’m quite happy, but naturally there are a few issues and I’m just working through them as best as I can.

So far, I’ve encountered the following issues and workarounds. I’ll circle back and go through them in more detail once I’ve finished with other setup tasks:

  • To install Qubes 4.1.0-RC2, I had to disable SecureBoot in the BIOS/UEFI. Installation was pretty smooth and as expected after that.

  • The WLAN didn’t work straight off the bat (with sys-net using Fedora-34 or Debian-11 as it’s TemplateVM). After a bit of researching, I had to move/delete a file in the TemplateVM for sys-net and it came good. Source: https://bugzilla.kernel.org/show_bug.cgi?id=212371

  • The Bluetooth adapter was continuously flapping (based on dmesg logs) in sys-usb so for now I’ve just disabled the Bluetooth module from within the BIOS.

  • I disabled hyper-threading in the BIOS as well.

  • I still need to check whether turbo boost is working properly or if it stays stuck on and around the base clock. I remember having to do some hackery on my prior QubesOS machine for this.

  • Simple file transfers via USB (both direct and via dock) seem to be very slow (both read/write). I’ve got to do a bit more investigation to understand where the slow down is; I am using good quality flash drives and get much better performance on other *nix based systems.

  • The wired ethernet LAN port on the dock does technically work (it’s a Realtek, not Intel), but I’m getting terrible transfer performance via speedtest and iPerf (~320Mbps). Plugging in one of my own USB to Ethernet adapters (based on the ASIX AX88179) and I get much better performance, i.e. ~880Mbps. Need to investigate further.

  • Had some issues with getting QWT installed in a Windows 10 LTSC 2021 installation so I’m building a Windows 7 SP1 Template to get up and running and then I’ll revisit the Win10 install.

This is my first Lenovo machine. As a general bit of guidance to anyone who’s purchasing Lenovo, don’t fall for their ridiculous marked up prices (and discounts) that they list on their website. Spend some time in the Thinkpad reddit and you’ll learn the ways to get the “right” price for your new Thinkpad. =)

Hope that helps.

1 Like

Thank you @cheerfultuck for this HCL report, which is now online.

Where are you finding the Lenovo Thinkpad P1 (Gen4) without nVidia graphics?

It varies from country to country and time to time. I was lucky enough to get a pre-built model with the specs I wanted, but if not, you can choose the customize option (on either the X1E4 or the P1G4; they are for all intents and purposes the same). In the customise option, if you choose the i7-11850H processor, it should give you an option to select the iGPU only:

“The i7-11850H processor is available with Intel Integrated UHD, NVIDIA® GeForce® RTX™ 3050 Ti and 3070 graphics cards.”

P1 (Gen 4)

X1 Extreme (Gen 4)

The Lenovo PSREF is a useful resource when trying get more verbose information about the hardware models and configurations available.


See my post on the P15 Gen 2. It works fine with the nvidia.

Hey, i had similar experience with P15 Gen 2 as you did with the WLAN and bluetooth adapter. Both very minor issues.

Everything else appears to work out the box. Not sure what issues you are having with USB. I did a quick test using fedora gnome disk utility benchmark feature on a USB3.0 drive and I was getting I think 100read and i think about 20 write. Not sure if that is good or not.

I am having this issue right now testing a P15 Gen 2 that has both iGPU and dGPU. The same external display works on a Thinkpad P51 (iGPU+dGPU) running Q4.0. It also works via HDMI to a Librem 14 running Q4.1rc3. On the P15Gen2 the display does not work (hdmi or usb-c).

You mention here messing around in dom0 to fix that and I was wondering what that fix is?


This issue is occurring because some vendors/models have the external display ports hardwired to the dGPU (if present) and there may not be BIOS options available to change this behavior. My previous workstation was a Dell Precision 7520 and although it had a nVidia M2200, the display outputs weren’t hard-wired to it so I could run external monitors off the iGPU which meant it worked well with QubesOS. Lenovo with their most recent gen of Thinkpads have made the decision to hard-wire external displays to the dGPU from what I’ve been able to determine.

From what I understand, “messing around in Dom0” would involve working through getting Dom0 to support graphics output via the nVidia GPU. This can be achieved via “nouveau”, a project orientated around open-source drivers for nVidia cards, but to be honest from what I’ve seen, it’s a bit of painful experience. I’ve always done what I can to avoid having to deal with it on a QubesOS machine; hence why I was only interested in the iGPU only models.

Another option could be by using DisplayLink (not DisplayPort) based adapters or hubs/docks. This involves installing DisplayLink software in Dom0 and thus you may be able to drive external monitors. DisplayLink may be OK for productivity type workloads.

Neither are ideal as you’re putting software in Dom0; which ideally you really want to keep as clean as possible. Sorry I couldn’t be of more help, I’ve always tried to shy away from dGPUs for my QubesOS workstation.