Lenovo G505s

Remarks

Suspend broken. Random freezes maybe issue with usb. sys-usb needs kernel option “irqpoll”. USB3 ports on left side broken due to missing firmware blob should be working as USB2 but really unstable could not assign any device to a VM. USB2 port on right side works.

All in all it is pretty unstable. Thinking about switching back to original bios.

If anyone is interested in my “coreboot build story” for this device just let me know :slight_smile:

Attachments

Qubes-HCL-LENOVO-INVALID-20211023-192635.yml|attachment (1.0 KB)

2 Likes

Remarks

Suspend working. No freezes at all. All USB ports working (USB2), no problems assigning any device to a VM (USB is slow, noticeable when copying files); dedicated GPU working (sys-gui) and so on.

All in all pretty stable. I’ve been using it for more than 2 years. Never thought about switching back to the original BIOS.

Maybe your laptop wasn’t working well anymore from the start (?). :wink:

It isn’t the fastest laptop out there (I’ve posted the time period for starting a VM somewhere in another thread) but it’s one of the cheapest (if you’re lucky) to be compatible with Qubes 4.0 and 4.1, it has no ME or PSP and with 16GB RAM it works well enough for me. I’ve put 2 SSDs inside and I use a Yubikey for U2F and to secure my keepass.

The only major problem I am having with this laptop is that the Qualcomm Ethernet controller is not working anymore above kernel 5.4.98. I am still hoping that a later kernel will solve the problem.

Thank you @dispuser5132 for your HCL report, which is now online.

Maybe you can still get it going with some help from @Raphael_Balthazar. I am sure you saw the multiple positive R3.2 reports of identical machines with Coreboot. So it ought to be possible to make it work.

In any case, negative reports are equally appreciated!

Some problems seemed to be fixed. The 2 ports on left side seem to work now without freezing the system anymore. I didn’t change anything not even update. But still only USB2 flashing again with xhci amd firmware makes the ports unusable. Assigning to VMs works now. Random screensaver problem didn’t happen again ( came up while i was typing, so that was strange).

Suspend still doesn’t work or to be more clear. laptop goes to sleep when closing the lid but does not wake up again. Blackscreen.

@Raphael_Balthazar helped me that some coreboot builds are broken. Seemed that we both followed the recommended build guides from Mike Banon on dangerousprototypes. When i was building with his patches my build failed. Thanks to Raphael :slight_smile:

For now i used my own dumped vgabios firmware from stock bios and an older coreboot version.

git reset --hard e6fb1344ed9188e19be4b54bdf1a76680b8c4523

based on mike banons github GitHub - mikebdp2/coreboot-g505s-builds: Some coreboot g505s builds for demo purposes. BUILD YOUR OWN !

for now it works ok for me. maybe i will try again a newer coreboot version with mikes patches.