Kernel in Debian-11 VM

I followed the steps from qubes documentation

  1. Created a debian-11 standalone template
    1

  2. Installed the distribution kernel image, headers and grub

  3. Shutdown the vm and went to:
    dom0 → Qubes VM Manger → right click on the VM → Qube settings → Advanced

and im trying to run with the PVH virtualization mode and the 'kernel setting of the ‘virtualization’ should be:

If Virtualization is set to PVHKernel → choose pvgrub2-pvh → OK

but this options is not present on menu, it only shows ‘pvgrub2’

and this options is for PV virtualization mode, however this mode is discouraged for security purposes and i dont want to use it, so, what am i missing? did i made something wrong? does someone had the same problem, how can i fix it?

Does HVM/(none) work?

I have not ever succeeded in booting with custom kernel in appVM other than installing the VM from scratch using a ISO file. I suspect that R4.1 has something different from R4.0 that the documentation has yet unable to cover.

1 Like

it doesnt work too
error

instead of Standalone i tried AppVM but using PV and it worked fine but thats not good as i said

I think you need sudo qubes-dom0-update grub2-xen-pvh.

i made a mistake, for running HVM i need to to disable memory balancing and because of it the HVM wasnt running so the procedure is quite simple, just create a standalone debian-11 with no kernel using HVM mode and it will work, and yes, i missed to install it grub2-xen-pvh thank you for the help @marmarek

@marmarek Is the official documentation accurate in regards to custom kernels for R4.1?
I have attempted to load a custom VM kernel which is stored in dom0 with no luck, I can only find that there has been success with the method @den1ed has used - StandaloneVM in HVM mode, using a custom kernel in the VM.