KDE - changing the way you use Qubes

@unman that’s all I found in previous posts.
Was an issue opened to have the icon in Networkmanager scalable, if that is the root cause of the issue?

Is there any fix to these missing icons please? I can’t find any solution whatsoever to this… sys net and blueman are completely white squares for me… the qui clipboard qui devices qui diskspace qui domains and whonix icons are all kinda very low res…

Thanks, this helped me get pipewire working with KDE. So far loving the experience a lot more than XFCE.

Have I missed something? What makes you think that scalability is the
issue? (I dont think it is.)

I never presume to speak for the Qubes team. When I comment in the Forum I speak for myself.

Sorry my bad. I read the first posts and didn’t find hints on root of the problem nor solutions, nor found nm-applet root cause of the issue myself. I guess fixing this requires upstream collaboration but would love to understand the root of issue first if you have insights @unman

Biggest issue so far is the audio latency with pipewire. There is around a 0.2s delay and is quite noticeable and there doesn’t seem to be a way to fix this.

hello @all :slight_smile:
i got a new computer and decided to freshly install latest qubes release 4.2.1 and switch to kde again to use activities and window rules.
first of all i have a general question about the new template naming in 4.2.1 → fedora-39-xfce/debian-12-xfce - why is the desktop env now specified in the template name?
i’m asking because i can no longer start any appvm gui after switch to kde and now wondering whether there has been a major change that prevents the use of kde or its just not longer compatible and perhaps thats why its explicit named xfce?

for the new installation i followed the docs: KDE (desktop environment) | Qubes OS
after reboot and switch to sddm, no appvm window spawns, but the vm is running without error messages. when i switch back to lightdm everything works as expected… any ideas whats going on? :frowning:

Qubes OS 4.2.1
Kernel 6.6.29-1.fc37 (same problem with 6.6.21-1.fc37)
Mainboard: X670E AORUS PRO X
AMD Ryzen 7000er series

thx in advance :blossom:

So that it is clear to users what flavor they are using.

No change - KDE is usable on 4.2 as before.
There are no KDE templates, but you can start with a basic template and
install all the KDE you want.

What vm are you talking about? What appVM window would you expect to
see?

I never presume to speak for the Qubes team.
When I comment in the Forum I speak for myself.

check if wayland was selected prior to login, and if so, switch to x11

Is anyone using KDE with tiling? Before I used bismuth and it worked great but it seems its no longer being maintained - it seems there is polinium for 5.27 but it seems, comparatively, feature incomplete?

Yes, I use the kwin script called Krohnkite. It is not flawless, but mostly works.

Great, good to know. So you are using it with the KDE 5.27? I used it before and can’t remember if it was that or bismuth that gave me problems. Polonium is waaay to buggy though.

Yes, here are the details:

$ plasmashell --version
plasmashell 5.27.8
$ kf5-config --version
Qt: 5.15.10
KDE Frameworks: 5.108.0
kf5-config: 1.0

Thanks for that. Just as an FYI I tried bismuth for sh*ts and giggles and it worked, in retrospoect, from what I read, the reason people stopped using it was that it didn’t work with wayland or kde6 (or both?) but as neither is an issue for Qubes yet I guess I can still do bismuth.
Still though, when kde6 and/or wayland do become a reality on Qubes I don’t see any good options.
Anyone tried combining KDE with i3? or maybe xfce with i3? I hadn’t heard of this before but it seems to be doable - at least on non-qubes systems.