Kali template available

Thanks for building this. It’s handy to have a Kali instance well integrated with Qubes tools.

Some feedback: could the tor package be turned off by default? Currently `` starts on boot in all VMs, which is not something I expect of Kali.

Yes it’s possible. Do you mind to open an issue (with kali label) for that with eventually any other things to tune. That will help me to remember. Thank you.

I am brand spanking new to the Qubes-verse. How do I update to 4.0.27-1 to 4.1?
-n00bs

It’s not currently possible. 4.1 is still in development and can currently only be installed from early alpha builds (or you can compile it yourself).

1 Like

Derpy derp. Thanks for the reply, that makes perfect sense.

On the other hand, some people around here have had good experience running Q4.1, so if you are adventurous, go for it. But this is probably not the best place to start your Qubes journey. You can get the alpha ISO from here: Signed Q4.1 alpha iso

1 Like

how about installing Lineage OS, android-x86 and Bliss OS on Qubes ?
anyone know any experience about it ?

Please help me in the link below

Hey, thank you very much for the template and ur description.
Can you explain how to increase the default max bytes that I can download the template?
I don*t know which command I have to run in dom0 terminal.
thank you again:)

On R4.1 alpha release, you just have to be sure to have dom0 updated :slight_smile:

Okay, I will try it. Then the default bytes size is bigger and I can install the kali template? I have dom0 update with the current testing repo and everyting is running fine so far.
thank you

tried it, but get the error: i need at least 1043 MB more space needed on the / filesystem. So I need to increase that? At my complete ssd where I installed Qubes, I have got a lot more space availabe and certainly don*t run out of space. How can I increase that? I like to test the kali template, too and sometimes I am stucked at those simple things… :wink: I saw that I need to increase my varlibqubes da volumes, there are only 9gb left and not enough. Is there a doc how or tool to do that easily?

I had the same issue here:

Thankfully @fepitre added a much smaller kali-core template flavor which you can compile with qubes builder.

Another solution is to clear the journal, since that should be responsible for a lot of your Dom0’s disk space utilization.

1 Like

cleaning journalctl give me 400 mb more. And good that it is not installed in dom0, then I will not have any installation problems with my space and don’t need to increase the lvm thin pool.
thank you :slight_smile:

can u tell me what files are installed to this part? just system files and there is nothing I can delete or if I will delete some other template’s ? And in general is it because I selected to use custom storage pools at installation and that is the new part of qubes 4.1? If I don’t click it at installation then it will be one “disk” ? And it is not possible to increse that volume via gparted or sth. similiar like that or?

What part do you refer to? The “RPM file to dom0”? If so, this is completely independent of default/custom VM pool. The transition between RPM file to your VM pool target needs RPM extraction process into dom0 filesystem. We cannot control this part (yet). This is currently a R4.1 bottleneck that we are trying to find what is the “best” solution with @marmarek.

I refer to the varlilbqubes data pool with 20GB ,but I think that I cannot be increase atm. No problem of course ,and Qubes 4.1 is just alpha and that is for trying such things and I will be sure that u and marmarek will find an solution.
So the only possibilty for me to test the kali template should be to do a fresh qubes 4.1 install and then install this template at first?, then the space should be enough and after installing it should be possible to install other templates, because none is so big like the kali one. In the vm pool I have got 700 GB left at the same disk, so I just have to pass one time the “extracting step”

thank you in advance and stay healthy:)

Yes you can install it at the very beginning but you can also resize the dom0 pool to something like 30GB.

that would be better to resize it for me, but I don*t know how to do it. But I will take a look if there is any documentation or sth how to resize this pool.
I can try it with a gpartd live cd. the unlock the complete partition and the it should be possible to see this partition and then encrypted it again. Maybe that is possible, or is there a easier and more secure way not to loose data from the dom0 terminal.
:slight_smile:

edit: gparted is not showing these partition whatever I do. I have to do it with LVM? IO need to read a bit at the weekend. Maybe I can fix it that will be great, because in future I will need more space in that part. cause I installed kde and else…

I tried to install qubes 4.1 with custom partition settings ,but always I select it, the Qubes 4.1 alpha.iso install crashes. Just installing with automatic partitioning is working for me

There is not qvm-volume extend or sth like that I can run in dom0 or to make it bigger;)?

So my “fix” was to reinstall qubes 4.1, and then at one of the first steps install the Kali template and then u have enough space left to install other things like kde or whatever u like. Think that was faster and more secure, then to change the root partition. I tried a few steps via lvm before, but got a smart event error at one of my disks, so I stopped it and did a fresh reinstall. While installing qubes 4.1 with usb it is important that no other usb is plugged in the notebook, because then u cannot create a usb qube and sys net fails to create with the error 4xxx. I have read this in an other topic but cannot find it and noticed that a second plugged in usb was my problem.

Hi everyone!

I left some feedback on the Kali template (R4.1) in the updates-status thread, along with the steps I followed in case anyone is unsure about how to install it.

if u are on qubes 4.1 then u only have to run the steps like described in post one here:
sudo qubes-dom0-update --enablerepo=qubes-templates-community-testing qubes-template-kali .
After installing open a terminal in the kali template and run apt update && apt upgrade as root, then u will be asked such thing, if ur a user of the “kali…” and some installation stettings. After installation u can select, like usual, some applications in the kali template settings of the qubes manager u like to show in ur starmenu and create kali based app vm’s and whatever u want :slight_smile:
Be aware that is only for qubes 4.1 alpha testing and not for Qubes 4.0x

Have a nice sunday and stay healthy lovely community

Ps: Maybe if u don*t have that anytime before u need to enable the testing repo via terminal or in the qubes manager - global settings - set testing updates at the dom0 section and run an update

I found an easy solution how to increase the root partition of dom0 for me and it works. If anybody has problems and the 20gb are not enough you can increase it using the kde-partitionmangager. This is available in sudo qubes-dom0-update kde-partitionmanager. Then u can select qubes-dom0 disk and increase the root to what size u need. Of course that is not a perfect solution ,but for people that don’t know how to do it with lvm or whatever it is a easy way.

Just a question: I cannot update the kali vm completely . At the qubes update manager it failed and if I do it in terminal there are 43 packages upgradable but if I run the command nothing needs to change. Is that usual or need I reinstall the vm and did a error at the first updating?
okay I now run apt-get autoremove and then apt-get update and upgrade again and now it is completely updated and everyhting is working :slight_smile:
thank you much:)

I was able to install kali template on a Dell 5520 with no special adjustments. The kali tools I tried ran fine. The only problem I had was that it would not update. It starts the update process but halts after only a few seconds. I tried it via Qubes update and CLI with same result.

on edit; I did not see that @rasta was having the update error. I will try his solution and see if it works.