Joplin, what is the best way to use it on Qubes?

Could you please suggest any way of using the Joplin app (note-taking) on Qubes a solid way?

I’ve tried so far:

  1. Installing and running it in an appVM as a flatpak with --user parameter. It does seem to work, however it reports some error related to being unable to reach file-picker (let’s say I need to import a file, but it’s impossible).

  2. Making a standalone VM (occupies much more disk space and will consume extra bandwidth indeed being the drawbacks). But even considering that, it stopped working after some time, reporting something that the app image won’t start. Don’t remember exactly now. But I can find the wording if this helps.

So I think, maybe I didn’t find any alternative way which is better.

Your suggestions are highly appreciated!

install the package xdg-desktop-portal-gtk (maybe xdg-desktop-portal-gnome or xdg-desktop-portal but the first should be enough), flatpak requires xdg-portal to offer a file picker


Thank you! I’ll try this out. Have no opportunity to do anytime soon.
I supposed it was installed. Don’t remember if I checked. But if it isn’t, then it’s clear that this causes the issue. Thank you again!

I’m an heavy flatpak user, I was surprised that this package wasn’t installed in the template to be honest. Firefox didn’t offer a file picker :rofl:


Thank you, @solene!
Your advice elegantly fixed the issue!
It was exactly the -gtk package that fixed it. I tried it last. Started with the portal only, then gnome, then gtk.

So I think flatpaks can be quite useful.
I don’t trust flatpak apps enough on Linux hosts. But with the approach to virtualization and isolation provided by Qubes, this can be an option for using some apps I need.

Thank you once again!

P.S. I wonder if there are other packages (not installed in templates by default) which can be essential to enable some generic abilities for flatpaks.

1 Like

Only xdg-portal is used as a “portal” through the sandbox.

1 Like

I run mine as an appimage, sourced here: Installation | Joplin

No issues, nothing configured. It runs out of the box :wink:

1 Like

Thank you, @klaus!

I did that as my second option. In a standalone VM. But I couldn’t make it work long, it would crash on start shortly after I started using it (just after several reboots). It reported I could restore the appimage or something like this. I didn’t try to fix it. By the way, it was recognized as an app in the qube.

Do you have it in a standalone VM, too? How do you launch it?

Hey there @cubicpyramid ,

I ran mine in an appvm, and not standalone. Haven’t tried that one, so I can’t report on any findings. Like you experienced, it was picked up on scan of qube for apps. I launch it from the programs list, although from cli in the folder its located it would just be ./nameOfAppimage to launch it. You might get some more details as to why it crashed, when running it like that…

Best of luck to you and have a great evening!

1 Like

Noted. Thank you!
Just one more question. Installing the app requires running the developer’s script. Did you install it in some template VM or in the appVM where you run the app? The files the script produces seem to be copied to /home.

You know, it used to be that was the process. Run a script and Joplin would be updated. Nowadays, I just update it by refreshing the downloaded appimage file from the link I provided above :wink:

Its an awesome note keeping app btw. I love Joplin. I used to use Scrivener, but they dropped support for Linux. Joplin is easily sync’d up via various means, I use a Nextcloud server. All my devices can sync up a local copy of my notes and be up to date. Good stuff! Used for personal and also my work for Red Hat.

Happy Friday to you Cubic and have a great weekend!

1 Like

Thank you, @klaus!!!
Happy Friday! Awesome weekend to you, your family, and all people!
I do like Joplin as well. Not very experienced with it. But I can say it does have features that make it a valuable app indeed!