Java program not working in AppVM or dispVM but works in template

So I installed a java program into the debian 11 template, updated everything and test ran, it worked fine.

Then I shut down and spin up a dispvm, for some reason when I run the same program it shows up
‘No suitable java virtual machine could be found.
Please define INSTALL4J_JAVA_HOME’

tried export INSTALL4J_JAVA_HOME=“path…”
Doesnt work.

Checked java install with readlink -f /usr/bin/java and it shows the path. Sudo apt install default-jre says latest version is installed.

What could be the issue here? Any ideas?
Thank you.

Did you install in the template or the AppVM that serves as the template for the disposable?

I could imagine that the installer of your Java program writes to /usr/local which is mapped to /rw and not to root. In other words: it’s part of the “private” part of a qube.

If you installed in the template proper, I would recommend you try and install in the AppVM that is the template for your disposables and see if it works then.

You went to great lengths not to mention what you are installing, so I assume you don’t want to share that information?