Issues installing signal with Qubes 4.1. Bullseye instead of xenial in main?

Thanks. Saw you updated your reply. thanks! Gonna try it out

1 Like

De nada, just passing along a few commands; all praise and thanks go to Moxie (zomg, no more dreads!) & the Open Whisper team.

Happy privacying!

1 Like

Thanks! Yeah i like signal. Moxie seems cool… whisper systems, etc. But i have issues still with my system setup… When i try to pass the built in mic i get this message: “pulseaudio agent not running”

I also have issues with usb on this laptop… I have some usb device when i start that says:
sys-usb;5-2 Generic _USB2.0-CRW_456789087 and a bunch of numbers…

Have i unplugged some usb cable or what… I just have issues with usb on this laptop… Any ideas? pulseaudio and usb issues… thanks again!

The best solution would be if i could just get the debian normal template signal commands on here… That would solve the issue… And get signal working, and that one has all of the “drivers” and such…
I could try and copy out them of the post that is written also, but yeah…
If someone feels like typing out the right commands or copy them here instead that would be the easiest solution really… to tired for this now… computers… fcuks sake. :wink: Something this easy, taking time… hehe
But i’m doing allot of other stuff at the same time so yeah… that’s that…
Signal could have some Qubes commands on their site also i guess…
“Signals official Qubes install guide.”

Mic issues… yeah i did install signal… but yeah… computers…
Kinda annoying… until you get them to work like you want to… and find a flow… I’m gonna quit re-installing stuff…

Pretty sure this will offer the audio support you’re after:

apt install pulseaudio-qubes -y

What you’ve got working thus far would work for the full debian-11 template as well.

I think that you need to have policykit-1 and qubes-usb-proxy installed in order to use camera and microphone. Below is the script that I use to create a debian-minimal template with signal-desktop and dependencies, typed using nano in a dom0 terminal:



# Clone template from minimal source:
# Install requirements:
qvm-run -u root --pass-io $TARGET_TEMPLATE 'apt-get install --no-install-recommends curl nautilus policykit-1 pulseaudio-qubes qubes-core-agent-nautilus qubes-core-agent-networking qubes-usb-proxy xfce4-notifyd zenity -y'
# Verify and install public signing key:
qvm-run -u root --pass-io $TARGET_TEMPLATE 'curl --proxy | gpg --dearmor | tee -a /usr/share/keyrings/signal-desktop-keyring.gpg > /dev/null'
# Add repository:
qvm-run -u root --pass-io $TARGET_TEMPLATE 'echo "deb [arch=amd64 signed-by=/usr/share/keyrings/signal-desktop-keyring.gpg] xenial main" | tee -a /etc/apt/sources.list.d/signal-xenial.list'
# Update package database and install signal:
qvm-run -u root --pass-io $TARGET_TEMPLATE 'apt-get update && apt-get install --no-install-recommends signal-desktop -y'
# Shutdown:
qvm-shutdown --wait $TARGET_TEMPLATE

The script works on my Librem 14 on the latest QubesOS 4.1.1 release. You can remove curl after installing the public signing key, and if you do not need a file manager, then you can remove the following packages from the script:

I hope this is helpful. Thanks to @Sven for the useful information in this forum which helped me to put this script together for myself.

Thank you to everyone in this forum that provides information and help. Learning to use QubesOS would have been a much more difficult experience for me, if not for all of the helpful people here.

1 Like

The one should probably also consider to check for libpam-systemd

1 Like

Yeah, great bash script… almost like i want to learn to code some sometime, maybe… Much easier with those bash install .sh scripts. :wink:
And it worked fine in a normal debian template, but i got usb issues so i’m gonna start another thread about that. But signal works fine now. (To write in anyways… gotta fix some random usb issues where some devices sometimes show up, and most often not…) Noice!

Thanks! Yeah but i did use cayce’s script and it worked fine… But it’s good to backup those anyways so i can install signal quick and easy in the future. :wink: I prefer the normal debian template over minimal though… Got space.
Yeah thanks for all of the answers in the thread! Enjoy your weekends. Peace out

Thanks for this also! But cayce… Do you know how to fix this issue? I did get the same “error” earlier while trying to install it…

#apt update
Get:1 bullseye InRelease [25.2 kB]
Hit:2 Index of /debian bullseye InRelease
Err:1 bullseye InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY D29FBD5F93C0CFC3
Hit:3 Index of /r4.1/vm/ bullseye InRelease
Hit:4 Index of /debian-security bullseye-security InRelease
Reading package lists… Done
W: GPG error: bullseye InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY D29FBD5F93C0CFC3
E: The repository ‘ bullseye InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I used your script and got that. Why? How do i fix it? Thanks again

These issues are due to lack of signing key being available to the apt package management system.

Maybe make sure that the file /etc/apt/sources.list.d/librewolf.sources doesn’t exist? If it does, remove it with root permissions or use sudo like so:

rm /etc/apt/sources.list.d/librewolf.sources

This is an artifact from the official librewolf Installation instructions for Debian based which uses different formatting than .list files and, may not be accepted and causing this issue.

Also, to be sure there were no errors or redundancy via running the above steps multiple times, you can safely go ahead and remove these files with root permissions or use sudo like so:

rm /usr/share/keyrings/librewolf.gpg
rm /etc/apt/sources.list.d/librewolf.list

Afterward, try these steps again “fresh”:

# 1. Verify & install official public software signing key
export https_proxy=
wget -O- | gpg --with-colons --import-options show-only --import --fingerprint | grep pub
read -p "Accept? (Y/n) " approve; approve=${approve:-Y}; if [[ "$approve" != [Yy] ]]; then exit; fi
wget -O- | gpg --dearmor -o /usr/share/keyrings/librewolf.gpg

# 2. Add our repository to your list of repositories
echo 'deb [arch=amd64 signed-by=/usr/share/keyrings/librewolf.gpg] bullseye main' | tee -a /etc/apt/sources.list.d/librewolf.list
1 Like

Thanks! Worked perfectly! Enjoy the weekend peace out

1 Like

Because we live in times where FUD hype gets the “likes” and, to add some color to the questionable fretting over the installation of libappindicator3-1

One (now patched) “dependency” that has been noteworthy within the past year is the LPE in polkit’s pkexec utility:

CVE-2021-4034 @ NIST

CVE-2021-4034 @ Debian

CVE-2021-4034 @ Packetstorm

What does FUD hype mean?

In this context, FUD hype

Ok thanks. Fear, uncertainty and doubt.
Yeah well that’s like your opinion, man. :wink:

Well, that can be your opinion as well :person_shrugging: but, in the case of libappindicator3-1 vs policykit-1, I’d use the term experience. :upside_down_face:

But, what do I know. :stuck_out_tongue_winking_eye:

When in doubt, ask MITRE which one’s threat profile is worse. :wink:

hehe ok then. :wink: True.

Hey again… Now i have this wierd issue where the mic don’t work… why? Is it because i have signal in a template? Its a normal template…
Gotta get my mic to work… Neither the inbuilt or an external gave off sound… wierd.
I have not got signal to work other then writing text… which i don’t want…
wanna talk. I managed to switch the mic to the cube… and record. But there where no sound recording

A post was merged into an existing topic: How do you add a microphone to a qubesVM?