Issue using Yubikeys on Qubes as GPG smart card: "selecting card failed: No such device"

There is a link to the guide on how to identify the right USB controller in the first step of the guide above:

after this procedure, this is what happened

After you performed all these steps?

  • Find the controller used for input devices.
  • Open the file /etc/default/grub in dom0.
  • Find the line that begins with GRUB_CMDLINE_LINUX .
  • Add usbcore.authorized_default=0 and rd.qubes.dom0_usb=<BDF> to that line, where <BDF> is the USB controller identifier.
  • Save and close the file.
  • Run the command grub2-mkconfig -o /boot/grub2/grub.cfg (legacy boot) or grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg (EFI) in dom0.
  • Reboot.

That’s the expected result. Now you need to perform last 8th step:

And create sys-usb. There is a link in the step on how to do it. You need to run this command in dom0:
sudo qubesctl state.sls qvm.sys-usb

sysusb.log (4.5 KB)

Here seems to be the same problem:

Check the output of this command in dom0:
sudo qubesctl top.enabled pillar=True

Run this command in dom0:
sudo qubesctl top.disable qvm.sys-net-as-usbvm pillar=True
Then try to create sys-usb again:
sudo qubesctl state.sls qvm.sys-usb

Do you have sys-net-usb VM?

no. only sys-net

Then it’s better to address this issue to @marmarek here:

I don’t have much knowledge at this and can’t help with this salt issue.

Yeah. I think there are a lot of bugs in this system. Some are resolved in the unstable branch. I seem to be stable. When to solve problems dick knows. )) Thank you very much for your help.

sudo qubesctl state.sls qvm.sys-usb
created a virtual machine sys-usb
what to do next ?

Do you see your USB devices (not keyboard/mouse) when you run this command in dom0?

I managed. Launched sys-usb. In the tray, I connected it to the desired virtual machine, and now VM sees it. Once again, thank you very much.

1 Like

YES!!! I see. Ave Maria. Fortune has turned

1 Like