Is it compatible/supported to have fedora and debian mixed in template manager?

I might have “messed up” in the template manager…
I got both fedora and debian mixed… Does that even work? I can’t update the fedora-34 one because of it… It keeps wanting to be installed in the update tool…
Is fedora recommended instead of debian?

And which should i pick in the global settings manager? Debian or fedora as template? This one is confusing me a bit… Could anyone explain a bit more on how you should not mix these, or how it’s supposed to be used? I would use debian over fedora if i could in all of qubes, but fedora is recommended right?
Or do others have them mixed up… I mean qubes has many ways to be used… I just don’t understand this really… If i can update everything and qubes it’s cool if they can be mixed in different ways on Qubes for me. Some dvm’s can use fedora…
Some appqubes like personal, untrusted can use debian and so on.

you may want to learn about qubes first, read this Introduction | Qubes OS

and for your question, basically you can run anything in domU it doesn’t matter you use fedora / debian, Some people here only use debian, or fedora only, or even mixing openbsd as sys-net, mirage as sys-firewall, whonix as sys-tor, ubuntu as sys-vpn.

You should meet the requirement before using qubes System requirements | Qubes OS

Then check your connection if sys-net and sys-firewall is working or not.

1 Like

Thank you. But i get this fedora-34 update error that’s the issue… If i mix them…
How do i update fedora-34 again? I use the update tool, but it keeps having the star symbol…
Even after reboot and i have tried installing the update. So how do i update it?
I think i read some easy solution last time… Forgot about it now. I would not get this update bug if i only used fedora i believe. How do i update fedora-34? Good if you can mix them.

I dont get an error i get this:
Updating fedora-34


        ID: dnf-and-rpm
  Function: pkg.installed
    Result: True
   Comment: All specified packages are already installed and are at the desired version
  Duration: 1956.782 ms

        ID: /usr/lib/rpm/macros.d/macros.qubes
  Function: file.absent
    Result: True
   Comment: File /usr/lib/rpm/macros.d/macros.qubes is not present
  Duration: 0.923 ms

        ID: dnf-makecache
  Function: cmd.script
    Result: True
   Comment: DNF cache successfully created
  Duration: 10459.372 ms

        ID: Disable deltarpm
  Function: file.append
      Name: /etc/dnf/dnf.conf
    Result: True
   Comment: File /etc/dnf/dnf.conf is in correct state
  Duration: 27.374 ms

        ID: update
  Function: pkg.uptodate
    Result: True
   Comment: Upgrade ran successfully
  Duration: 27087.489 ms

        ID: notify-updates
      Name: /usr/lib/qubes/upgrades-status-notify
    Result: True
   Comment: Command "/usr/lib/qubes/upgrades-status-notify" run
  Duration: 3895.424 ms

Summary for fedora-34

Succeeded: 6 (changed=1)
Failed: 0

Total states run: 6
Total run time: 43.427 s

… Is that called an error if the fedora-34 keeps wanting to be installed? How do i get it to just be installed and stop showing up again and again? It’s not an error… maybe a design bug?

It looks like a known bug in Qubes Updater. Here is the recommended update routine until the bug is fixed: How to update | Qubes OS

I get this if i try to update fedora… You know to do? fix dependencies?

Problem: cannot install the best update candidate for package librewolf-99.0.1-1.fc34.x86_64

  • nothing provides needed by librewolf-99.0.1-1.fc35.x86_64
    Package Architecture Version Repository Size
    Skipping packages with broken dependencies:
    librewolf x86_64 99.0.1-1.fc35 57 M

Transaction Summary

Skip 1 Package

Nothing to do.

It did update now, but skipped librewolf

You can try to update Librewolf manually. I guess it should be something like
sudo dnf install Librewolf