Interface freezes after a vm shutdown - Qubes R4.0 - Thinkpad x230

Hello,

I am a new user of Qubes OS R4.0 up to date on a Thinkpad X230.

I have an issue when I shutdown a virual machine by the Qube Manager or by the terminal inside the VM itself (shutdown -h now), the gui freeze and I only can move the mouse.
After that, I have to hold down the power button to turn off my computer.

I don’t know where I have to look to get more informations. I don’t understand where to find informations in /var/log.

Do you have an explanation and / or an idea to help me to solve this issue ?

Thanks.

Julien

Hello,

I continue to search and investigate.

The problem occure when I shutdown a specific appvm with 1TB of datas inside.

When I shutdown this appvm by the qubes manager in the GUI or when I use the command qvm-shutdown --all, the GUI freeze and If I use the second tty (ctrl +alt + f2) it doesn’t work anymore. I have to do an hardware shutdown.
I have no specific error in journalctl except this one :
qubes.WindowIconUpdater: personal -> dom0: denied: qrexec-client failed

Is there a way to fix this problem because I think that my datas will be damage after all these hard dirty shutdown…

Thank you for helping me.

Julien

You have a qube with 1TB data in private storage?
On an x230?
This seems so far outside the expected use that I’m not surprised your
system is at breaking point.

I do know people who run 1TB or more in private storage, but they use
machines adequate to the task.
Frankly, after the second (maybe the third) freeze, I would be looking
at alternative ways of organizing my data. Insanity is repeating the
same mistakes and expecting different results.

Maybe you could look into adding all the extra storage on an external drive and auto-attaching it on boot to the qube in question?

Thank you for your response.

I find nothing about storage limitation. Also, I think that it is the usage, separate your digital life into domains, one of them is my personal domain with my familly photos and videos…
X230 have a litlle screen but an Intel i7 and 16 GB of ram with an 2 TB ssd. It’s not so bad for this use I think.

This is not repetitions but investigation :wink:

thank you for your tips, I will try that if I find nothing else to solve my issue. :+1:t2:

1 Like

Hi @anon42940733. I agree with the suggestions to have the data elsewhere - possibly on a NAS…

In the meantime, I would see if it’s possible to get more insight into what’s going on. For example,

  • Disable any autostart qubes
  • Reboot - only dom0 should be active
  • Open a terminal and do “xentop -f”, then hit “s” 3 times to sort by CPU
  • Open another non-overlapping terminal and do “top”
  • Open the Qube Manager and start your monster qube (which will also start any NetVMs needed), but don’t run any application in it
  • Watch the terminals, and when everything is calm again shutdown your monster qube and in the terminals see what runs/hangs

If this works, you can add further steps. If not, I’m out of ideas. :frowning:

Thank you for your answer.

I did what you write.
In xentop I see dom0 and then the appvm personal. When I stop appvm personal, it close disapear from xentop but dom0 use 100% of cpu .

In top I have a kworker that use 97% of cpu.

It works from 3 hours now and don’t stop.

I don’t know why it use so much cpu.

thank you

You have a 2TB SSD, and a qube with 1TB in private disk.
Look at the volumes under /dev/qubes-dom0
These are links to volumes under /dev
In particular look at vm-XXX-private and vm-XXX-private...-back
You could mount these in dom0.

Also, run qvm-volume info XXX:private, and look at “size”, “usage” and
“revisions_to_keep”.

1 Like

Hello,
thank you for you message.
I have the following property :
revisions_to_keep 1
save_on_stop true
save_on_start false

I have 7 revisions to keep, it’s not logical isn’t it ?
Also, is it possible to set save_on_stop to false ? I don’t understand the purpose of save_on* property.

Hello,

I have set save_on_stop to false, remove all lvm Snapshot, set revision_to_keep to 0 in qubes.xml, but after each dirty shutdown I have more than one revision and I still have the bug.

Do I have to create an issue on github or the problem is my use case ?

You should almost never have to edit qubes.xml directly.
qvm-volume set qube:private revisions_to_keep 0 will stop saving
revisions.
You should see that any private-xxx-back volumes are gone - although given
the likely state of your system I would check this and make sure you
have sufficient space.

You might find it more reasonable to move the bulk of the data on to a
storage volume that you attach to the qube as you will.

1 Like