Installing Redshift on Qubes 4.1.1

I’ve been after using Qubes for a while and over the weekend took the plunge to install it on my computer, and it’s all gone well so far.

The first program I need to get working is Redshift in order to protect my eyes (I’ve got a big screen!).

I installed it no problem in the Debian-11 Template, using the Terminal command sudo apt install redshift

Terminal connected to the internet, and has installed it (Redshift version 1.12-4.1)

Afterwards I ran the Qubes Update comman from the Qubes Tools menu.

However I have no idea how to launch it - it doesn’t appear to be anywhere. I’ve opened up the debian-11: Qube Settings in the debian-11 Template tab, and checked under the applications tab, and Redshift isn’t there in the Available section.

I’ve next checked the personal:Qube settings in the personal qube tab, and again, Redshift isn’t there under the available programs tab.

Appreciate help in where I should look next!


Hi @DW55 and welcome to the Qubes OS community!

The forum has a search function and if you search for redshift the first hit is a guide on how to install it. :wink:

1 Like

Hi Sven,

Thanks for getting back to me so quickly :slight_smile:

Yes, I’ve already tried the guide on the forum, and it doesn’t work - running that command line doesn’t do anything.

I’ve already successfully installed redshift by using the Terminal command sudo apt install redshift

The problem I’ve got is that Redshift is nowhere to be seen on the system.

This is the issue I have, it’s been successfully installed but I don’t know how to open it.


You are installing it in a template, but you need it in dom0 or sys-gui (if you have one). The guide tells you to do these things in dom0:

  1. create ~/.config/redshift.conf
  2. install redshift and redshift-gtk (optionally)
  3. hook them up to autostart

redshift is a command line program and wouldn’t show up in your menu. redshift-gtk will, but again: you need it in dom0 and NOT the template. Maybe read that guide one more time carefully.

1 Like


Sorry to be rude, but did you really read the link @Sven just posted ?

I just tried it and it works. If you had read the doc you would not have used this command sudo apt install redshift, just because you have to install in dom0, and you can’t use sudo apt install in dom0.

In dom0 you have to use sudo qubes-dom0-update redshift etc.

1 Like

Gotcha, that makes more sense thanks.

I’ll play around with it a bit more and see how I get on

1 Like

I’d like to add that the linked guide above on how to install redshift says something about creating a startup-script.
What I did and what worked for me was also installing qubes-dom0-update redshift-gtk - this helps in getting a systray icon, which has an “Autostart” option. If it is checked then redshift starts automatically without any additional script.