Installation seems successful but can't boot X

I - think to - have successfully installed Qubes OS 4.0.3 on an external USB disk.

I used a 16GB USB drive to write the ISO to, booted from it and then installed it to a different USB drive of 64GB.

I got some installation success message, but the system did not reboot, it was hanging with a black screen and some “The system is now rebooting” or so message.
The newly installed system in fact was not able to actually boot on starting from scratch.

I followed the “Boot device not recognized after installing” instructions at

Now the system boots - but not completely: I can’t get an X system up. I see lots of boot messages and then at some point there is a “The SESSION_MANAGER variable is undefined” error and then a series of other error messages (can’t copy paste) indicating that it just can’t start the X Window system. After several retries it then stops trying and just hangs.

Can’t enter some other tty with Ctrl-Alt-Fx for example.

Any suggestion?

I run Qubes on a USB3 stick and it works pretty well for me, but only when plugged into certain devices. With others I get errors similar to yours, or indeed other errors. What laptop or PC are you plugging the USB stick into?

Hi Plum,

it’s a Dell XPS 9360. Haven’t tried anywhere else, maybe I should!
Thanks for chiming in.

I’d have thought a Dell XPS would be OK.I’m guessing you’ve fiddled around with the BIOS setings, UEFI etc, see if that makes any difference? Other possibility might be a dodgy USB stick. QubesOS is fussy

Oooh - I think it is configured to boot in legacy mode…should it be EFI?

I am afraid to break my existing manjaro installation there though if I do that

Actually this kills my project I had in mind.

I was hoping I could take that USB everywhere with me and boot anywhere from it to have a secure system at all times.

Doesn’t look like it’s easily possible if it is that fussy with boot up.