Installation of Qubes on Thinkpad E14 Gen2 results in black screen

I’m trying to install qubes on a new thinkpad laptop.
E14 G2 20TA005GIV I7-11 32G 512 NVMe\FP\BLK\14" FHD\FD\3Y

I created a bootable usb as per the instructions provided by the qubes team, using livecd-tools. I managed to boot the installer but eventually the installer freezes, after xen relinquish the console, sometimes it allows me to move the mouse cursor but only shows a black screen. In addition, when clicking the shutdown button the system shows the qubes logo with a progress bar before shutting down the machine.

I used a usb with a partition size less than 8 GB, as recommended, and tried different versions (4.04, 4.1a, 3.2), without any luck.

I tried changing the parameters of the boot option field as per the UEFI troubleshoting page](UEFI Troubleshooting | Qubes OS), and I attempted several solutions suggested in this github issue to no avail.

Unfortunately my laptop doesn’t support legacy boot.

I consider removing my SSD and installing qubes on it using my old machine, what do you think? Does anyone has a more elegant solution?

for newer hardware try with 4.1

I’ve looked into thinkpad e14 gen 2 psref. does your type has discrete graphic ? can you set your gpu to discrete only ? if possible try with discrete only gpu and go with uefi its okay.


Many thanks for your response!
And I bet you’re right, this is probably a graphic-card issue, my laptop has Intel Iris Xe Graphics, after checking I realized many it is a common issue with qubes and with linux distros as well. Unfortunently, I’m unable to change the GPU configurations in the BIOS.

Regarding your suggestion to use the latest kernel, I’m a bit concerned since the ISO you linked to is using a public key not signed by the qubes team master key.

Do you or someone else have other suggestions?
Or can anyone provide basic instructions on how to replace the current kernel in a qubes signed release with a newer one?

Thanks again for your help.

yeah it’s signed by fepitre bot 1C8714D640F30457EC953050656946BA873DDEC1

it’s for CI purpose, give it a try and send hcl reports :blush:

I intend to fill-up a hcl report soon, but unwilling to boot an unsigned ISO. Even for testing purposes.

I’ll wait for an official release/beta :slight_smile:

1 Like

zero trust :clap:
hope we will get newer official 4.1

1 Like


Good choice. From what I understand if you were to use 4.1 weekly releases you wouldn’t be able to update software and you have to install the next week’s software to have it up-to-date. Is this correct?

When you updating dom0 for first time, it will ask you in terminal if you want to import qubes team master key or not.

This is wrong. Installing weekly builds only means installing Qubes OS with the current repository packages and updates. You can update as would be a normal Qubes OS R4.1 build. I’m using my own builds since more than one year already and everything updates as expected :slight_smile:


This one is not only for CI purpose. I would not have setup a whole signature pipeline inside a Qubes build sane environment…I try to make people testing upcoming Qubes release with a more trusted content than just ISO built in a random build env.

OK. Thanks for the clarification. I don’t know where I got that idea from, then.

1 Like

I made a HCL post for my E14 (I had the same black screen issue, that is fixed with the new kernel) HCL - Lenovo ThinkPad E14


I’ve installed the beta of Qubes 4.1 successfully, but the machine doesn’t resume from a sleep. Can you please confirm whether the sleep and resume work for you?

Many thanks

Has anyone came up with a solution?
The problem still persist in the updated versions of 4.1 release.

what laptop your using, not much device are able to resume from sleep

Happy to say that the sleep issue was resolved by upgrading the bios of Lenovo e14 Gen2 model.