Installation failing on new PC: "The installation cannot continue"

I am trying to install Qubes 4.0.4 on a new PC, but get the following text error message:

Starting installer, one moment...
anaconda 25.28.9-1 for Qubes R4.0.4 started.
* Installation log files are stored in /tmp during the installation
* shell is available on TTY2
* If the graphical installation interface fails to start, try again with the inst.text bootoption to start text installation
* when reporting a bug add logs from /tmp as separate text/plain attachments
15:47:12 Not asking for VNC because we don't have a network
15:47:13 X startup failed, aborting installation
15:47:13 X startup failed, aborting installation
The installation cannot continue and the system will be rebooted
Press ENTER to continue

I have installed QubesOS before on a different PC with success, (although some aspects of it did not work).
This is a higher-spec PC now.
I am booting from a USB drive with the ISO on it.

How do I start a text installation instead of the graphical one?
How do I access and save the logs stored in /tmp as the system has halted and cannot do anything other than reboot?

If the graphical installation interface fails to start, try again with the inst.text bootoption to start text installation

Reboot your pc,
Select install qubes and press ‘e’ and add inst.text option there then f10 to continue.

THis is a common issue. Please read: Installation troubleshooting | “Not asking for VNC because we don’t have a network” / “X startup failed, aborting installation” / “Pane is dead” error during installation.

1 Like

Thanks. I pressed E but nothing happens. When selecting Install Qubes, the only options that work are ENTER and arrow keys.

Update: I saw that I could press TAB and add the inst.text to the option and that allowed me to get further into the installation.
I then had a problem as it turned out that SVM was not enabled for the CPU in the BIOS to enable any virtualisation, so I enabled that.

udpate: i am getting further with the text installer, but when choosing the partition to install to, I get the following:

storage configuration failed: autopart failed:
Encryption requested for LUKS device nvme0n1p6 but no encryption key specified for this device.
Encryption requested for LUKS device nvme0n1p7 but no encryption key specified for this device.

This happens regardless of which option I choose (Standard, Btrfs, LVM, LVM Thin Provisioning).

There are 3 partitions on the internal SSD. First is for uefiboot, second for Ubuntu, third is empty but formatted as ext4, to take the Qubes installation.

The options it gives:

Autopartitioning Options
[ ] 1) Replace Existing Linux system(s)
[ ] 2) Use All Space
[ ] 3) Use Free Space

Whichever I choose of those I get the same error as above.

I don’t understand what it is trying to do with nvme0n1p6 and nvme0n1p7 as those partitions do not exist. nvme0n1p1 nvme0n1p2 nvme0n1p3 exist, that is all. None of these is using any encryption of any kind.

So any ideas how to get past this error?

I installed Fedora 34 on the same PC, from a live USB ISO, and it installed in graphical mode. What is so different about Qubes compared to Fedora, which it is based on, that the graphical installed will not work where the Fedora one does?

There might be many reasons for this, but for starters, the distribution in dom0 of Qubes 4.0.4 is Fedora 25. You would have to check if the Fedora 25 live iso works.

You can also try a beta release of Qubes 4.1, which uses Fedora 32.

I downloaded the 4.1 beta, and tried booting that. I get into the installer, and it gets as far as it did before, but without the X startup failed errors – instead, it just goes to a completely blank screen and nothing is responsive from the keyboard. I tried safe graphics mode as well as normal mode. I get the same if trying to boot into text mode to install.

I tried the text installation again, and this time I got further, and it installed.
I then rebooted, but the system is hanging after trying to boot into Qubes.

I have downloaded Qubes 4.0 as a virtual machine, which works in VirtualBox.

Just keep in mind this is discouraged in the installation guide:

Note :information_source: : Qubes OS is not meant to be installed inside a virtual machine as a guest hypervisor. In other words, nested virtualization is not supported. In order for a strict compartmentalization to be enforced, Qubes OS needs to be able to manage the hardware directly.