Install Qubes R4.1.2 on MacbookPro 2019

I`m trying to install (Dualboot) Qubes on my MacbookPro 2019 i9 (with T2 Security Chip)

This is what I have done so far:

I downloaded the ISO file, verified it and flashed it to an USB stick. After flashing I re-verified the installer medium.

I disabled all Security setting of the T2 chip in Startup Security Utility. (Secure Boot - No Security & Allowed Boot Media - Allow booting from external or removable media)

Booted into the Startup Manager and chose EFI boot.

Chose the option: Install Qubes OS R4.1.2 (I also tried all other available options with the same result)

Then I get the following:

BCMDHD_ExitBootService: ENTER
dhd_os_wifi_platform_set_power: Setting wl_reg_on to 0 succeeded
dhd_os_wifi_platform_set_power: Setting wl_reg_on to 1 succeeded

I have waited for around 1 hour and noting else happens.
Pressing ENTER shows no result either.

I have tried the same with an Ubuntu 22.04.2 Installer, then it shows the same lines but switches to the installer window after a few seconds (mouse and keyboard don`t work though)

Any suggestions how I could make this work?

1 Like

in grub menu, add efi=noruntime on kernel parameter

Thanks for your reply.
I have tried this but Im unable to boot with CTRL X and the MacBook has a touchbar, so I cant use F10 either.
I have tried with an external keyboard which also didn`t work. (Both CTRL X and F10)

I have tried to change the script manually on the installer medium but wasn`t able to save the modified files…
I saw there are some programs to edit Grub. Would that be an option or is there anything else that I could try?

I’m not sure with that program since it “may” be different with the qubes do, but here’s what qubes do to produce iso

	chmod og+rX -R $(BASE_DIR)/os/
	xorrisofs -o $(BASE_DIR)/iso/$(ISO_NAME).iso \
		-R -J -V $(ISO_VOLID) \
		--grub2-mbr /usr/lib/grub/i386-pc/boot_hybrid.img \
		-partition_offset 16 \
		-append_partition 2 C12A7328-F81F-11D2-BA4B-00A0C93EC93B $(BASE_DIR)/os/images/efiboot.img \
		-iso_mbr_part_type EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 \
		-c boot.cat --boot-catalog-hide \
		-b images/eltorito.img \
		-no-emul-boot -boot-load-size 4 -boot-info-table --grub2-boot-info \
		-eltorito-alt-boot \
		-e '--interval:appended_partition_2:all::' -no-emul-boot \
		-graft-points \
		.=$(BASE_DIR)/os \
		boot/grub2/i386-pc=/usr/lib/grub/i386-pc

extract your iso, add the kernel parameter in grub config, modify above code to your extract dir and run the command.

I tried the following but still couldnt make it work... Maybe I did something wrong? I had to modify the code a bit as it didnt run otherwise. (I tried just adding the kernel parameter and then created the ISO with mkisofs but had problem of missing partition table)
When I do those steps I get into Grub but when wanting to install I get the error that pxeboot cant be found. Did I add the kernel parameter to the wrong file or did I make any other mistake? Im not in the IT field so it`s kind of complicated for me and lacking some basic knowledge…

Set up new machine based on Debian 11 and ran the following:

sudo mkdir /mnt/iso
sudo mkdir /qubesTEST/
sudo mkdir /qubesMODIFIED/

	sudo mount -o loop Qubes-R4.1.2-x86_64.iso /mnt/iso
	ls /mnt/iso #CHECK
	sudo cp -r /mnt/iso/* /qubesTEST/
	ls /qubesTEST #CHECK
	
	sudo open /qubesTEST/isolinux/grub.conf
	
	###ADDED to KERNEL PARAMETER "efi=noruntime"

	sudo apt update && sudo apt upgrade -y
	sudo apt-get install xorriso -y
	
	
	sudo chmod og+rX -R /home/user/qubesTEST/
sudo xorrisofs -o /qubesMODIFIED/Qubes.iso \
	-R -J -V QubesMOD.iso \
	--grub2-mbr /usr/lib/grub/i386-pc/boot_hybrid.img \
	-partition_offset 16 \
	-append_partition 2 C12A7328-F81F-11D2-BA4B-00A0C93EC93B /qubesTEST/images/efiboot.img \ 
	-iso_mbr_part_type EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 \
	-c boot.cat --boot-catalog-hide \
	-b images/efiboot.img \  ### Could there be a mistake in this line? 

###It wouldnt run with "eltorito.img" as its not in the files
-no-emul-boot -boot-load-size 4 -boot-info-table --grub2-boot-info
-eltorito-alt-boot
-e ‘–interval:appended_partition_2:all::’ -no-emul-boot
-graft-points \
/qubesTEST/
boot/grub2/i386-pc=/usr/lib/grub/i386-pc

	###Move .iso to USB
	
	sudo dd bs=4M if=/QubesMODIFIED/QubesMODIFIED.iso of=/dev/sda status=progress oflag=sync

I really would appreciate if you have some advice for me on how I could proceed.

if you trust me you can use this iso, this was qubes 4.2 with gnome de and fedora template only, i also add the kernel parameter for your case. Qubes-51lieal.iso - Google Drive

Relevant?

My best advice for Linuxing on Apple hardware is to always have an external USB keyboard and mouse handy.

They go a long way in helping you when you’re unsure if your built-hardware will behave :slight_smile: