In vm kernel over dom0 kernel

In vm kernel over dom0 kernel

Ive set the kernel option for all VM’s to “none” and every time I try to start any of my VM’s I get approach with the error messgae

“virt_mode PVH require kernel to be set”

Sys-net is the only vm working for me with the in vm kernel, the virt mode for sys-net is HVM

VM’s that don’t work because of this are

Whonix gw and ws
(All of these have virt mode pvh, not trying to use hvm for these only pvh, even when I tried hvm it told me that there was an issue with the grcexe agent.)

Could any one help me with this issue because I can’t even do anything in qubes with this issue I have.

Edit: for people that thing that using no kernel means that the vm has no kernel to use, this is wrong, setting the option to none makes the kernel use its own vm, this is what another user told me

The none option only uses the in vm kernel for HVM VMs. For PVH VMs, you need to select pvgrub2-pvh (pvgrub2 for PV VMs, if the need ever arises). However, this requires first installing the grub2-xen-pvh (or grub2-xen) package in dom0.

Bummer I looking to change my kernel before networking, qubes-whonix is pretty secure but if you want to additional hardening it requires networking, my isp and plus the people who I’m trying to stay secure from is why I need the extra hardening bummer :frowning:

Do I get you correctly that you only want to give network connectivity to qubes running with an in VM kernel?

If so, you should be able to temporarily set the dom0 update qube to sys-net (which you already have running the in VM kernel), install pvgrub2-pvh and go on as planed from there. Am I missing something?

Yah you are right, but to do any of that to install the package anywhere in the first place it requires networking and I was trying to be use the use the in vm kernel without any networking involved to begin with.