Im having trouble keeping persistant downloads

I don’t download many programs because most of my life is in a browser, but there are a few programs I do need. One of them is my VPN. I download and install it in the sysnet qubes like I do with any fedora installation but whenever I shut down the VM, everything gets wiped. The actual .rpm file is still in my storage but all my settings and login details are reset, and I have to reconfigure everything. I use mullvad VPN. In other qubes when i try to install something, the storage will completly wipe the program. I have tried installing things like signal in a debian VM or things from flatpak in other VMs. When I do get the app to install (still not permanently) it won’t give the option in the applications tab in qube settings to have that as a saved app. I have installed qubes about 5 or 6 times, but I get the same problem every time. Thanks for your help in advanced.

This is a common pitfall when learning Qubes. See the following answer:

1 Like

so any app i want to install on a qube i have to install to the template? unless im misunderstanding something, that sounds a bit counterintuitive to me. it makes sense, but that’s the only solution? thanks for you reply.

There are solutions to this but they are more complicated.

It’s like this because many qubes share the same root file system,
saving on space and making it easy to configure. Otherwise you would need
to install an application in to every qube where it was wanted.

If you just want an application in one qube,you might consider a
standaloneVM - see the docs for help.