I3 qmenu not launching applications

I’m using i3wm, and just discovered qmenu contributed package and it seems potentially very useful.

There are 3 utilities, qmenu-vm, qmenu-dm, qmenu-al. The VM manager and Device manager work great. I am having problems only with qmenu-al, which is supposed to launch applications.

qmenu-al is not launching applications. It seems to attempt to launch, but instead it just reopens the same dmenu and does not launch or even start the VM.

Interesting that, if I run it from the terminal on dom0, then qmenu-al actually just prints a command to stdout. This does not happen with qmenu-vm or qmenu-dm. For example, if I run the command, the dmenu will popup, and I select Firefox on my Debian DVM. Then it just returns the command that I would run if I were to do it myself (and nothing else happens).

[user@dom0 ~] qmenu-al --all
qvm-run -q -a --service --dispvm-debian-11-dvm -- qubes.StartApp+firefox-esr

This does not happens with qmenu-dm. Instead, the dmenu pops up, I make some selection, and everything works (with no stdout).

[user@dom0 ~] qmenu-dm --all

Is this a problem with my config or usage? Or should I open an issue in GH?