I deleted some TemplateVM

Hello, I just finish downloading Qubes, and deleted templatesVM in the Qubes manager without thinking that they will be deleted from the pc, I thought it was default VM and so I could create some news ones. I can’t find a way to reset the pc, how can I do?

Templates can be reinstalled.

Review the documentation on templates.


1 Like

Hello @cayce i’m not sure about what else I deleted, but i’m pretty sure that there is a Whonix missing. I link two photos


Get the medium you used to install Qubes, and mount it in dom0.
If it was a USB stick , interrupt the boot process, and in grub, select
e to edit the boot parameters.
On the line that starts module \vmlinuz, look for the parameter
rd.qubes.hide_all_usb, and delete it.
Boot the edited command line - F10, I think.

Now the US stick will be attached to dom0 when you insert it: you should
be able to identify it with dmesg when you attach it.
In a terminal in dom0, run sudo mount DEV /mnt - replacing DEV with
the device name of the USB stick.

The templates can be found at /mnt/Packages - they are named

install the templates you want with qvm-template reinstall /mnt/Packages/NAME
replacing NAME with the full filename.
e.g., qvm-template reinstall /mnt/Packages/qubes-template-fedora-37-4.0.6-202302271646.noarch.rpm

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.

Can you see now? I edited the message


Looks hard to do, do you have by any chance a way to reset the OS? I don’t find anything in the settings.

You shouldn’t need to reset the OS. You can follow the commands above from @cayce if you’re missing a specific Qube.

What do you think is missing?

Also, if this is a fresh install and you want to reset it then you can simply redo the installation.

Edited the title a bit. I get you’re frustrated but the subject works just as well without the f-bomb.