Hyperthreading not working on 3 Systems


i had Qubes on 3 different Systems so far. All capable of HTT as lscpu announces and it being activated in the BIOS.
But lscpu also states, that i only have one thread per core on all machines.

Does someone have tips on how to troubleshoot this?

Thanks for you help!

Hyperthreading is disabled in Qubes for security reasons. Can’t find better sources than


Thank you very much!

I thought about security considerations but wasn’t able to find a source…

Hi @wishtohope and @fsflover,

a good source : Qubes Security Bulletin (QSB) #43

Part of the mitigation is to disable hyper-threading...

Note that BIOS settings allow in general to deactivate hyper-threading, and it’s a good idea to do it on all your machines (not only Qubes OS machines).

1 Like