HP zBook G2 i7 install issues

All virtualization activated in Bios. Checked that several times. Tried UEFI with CSM and UEFI without CSM.

Internal new, empty 250gb ssd, 8gb ram. Recently updated bios.

Installing from 8gb usb stick. Install goes smoothly to the beginning of “language” selection. Then I get the error…

“Unsupported Hw Detected”. “Missing features: IOMMU/VT-d/AMD-Vi, Interrupt Remapping.”

Guidance appreciated.

Hi @Tycho,

What is your CPU ? Any AMD / Nvidia GPU ? Any very specific hardware?

Below some ideas :

  1. Test the boot media : check the ISO signature, check the USB stick (no failure sectors?), use a bigger USB stick (>=16GB), check the ISO copy to USB stick
  2. Check the uefi-troubleshooting documentation
  3. Check the installation-troubleshooting documentation
  4. You checked the virtualization in the BIOS, really all the virtualization parameters? Check again the BIOS requirements documentation (IOMMU, VT-x, …, yes all).

Other related topics:

  1. Legacy Mode worked for murdock’s HP zBook G1 (@murdock)
  2. See the HCL report for this HP zBook G3 (@dispuser5132)

I hope that one the above idea will help you in your quest.

I just found an HP zBook G2 user (@missing_email_user), maybe he could also help you…

Seems to be an unsupported CPU.
HP builds ZBooks with CPUs with VT-x (virtualization support) but without VT-d also.
Please post your CPU identifier.
I have changed the CPU from my ZBook from I7 4700MQ (without VT-d) to i7-4800MQ (with VT-d) for that reason also.

Thanks everyone. After revisiting the bios, i noticed no V Td to be found. The cpu is i7 4710MQ. So it seems that Im at a dead end on this box without a cpu upgrade.

The 4800 cpu is on Amazon (used) for $190.

Perhaps I could recoup some $ on the sale of my used 4710. Not looked into that yet.

What to do… what to do.

Penny for your thoughts?
Thanks again for everyones guidance.

What about updating the BIOS to a newer version?

(People, funny things were happening in this thread because @missing_email_user was mentioned. – some replies were getting repeated. It should have been fixed now.)

Updated bios to most recent hp had to offer a few days ago.
Thats why Im thinking this might be a limitation on the cpu.

Thanks for helping a qube noob.

1 Like

@murdock Did the cpu upgrade allow you to successfully install and run qubes on your zbook?

Bios recognize the new feature on the new cpu?

Yes, because for my ZBook exists a list with possible CPU options. I have used an CPU, that is listed in the docu as option for my ZBook. So Bios recognizes the new CPU without any problem and switches also the VT-d feature to enabled.

After the CPU upgrade, i was able to install and use Qubes (i use it currently). The only problem (but that is not connected to the CPU upgrade) is/was, that i cannot use EFI, i must use legacy bios.
That seems to be a problem with the rather basic support in XEN, if qubes switch to grub + efi, i expect the succesfull usage of efi on my zbook.