How to unbind alt-scroll with zooming?

Hello everyone!
Is there a way to unbind alt-scroll with zooming inside VM’s? I use a windows standalone VM and inside that I use illustrator and I can’t zoom inside the program because it has the same shortcut for zooming.

Thanks in regard, Bablet :slight_smile:

I am unsure what you refer to. I cannot see such a keybinding (in the shortcuts), nor does it zoom into my kali HVM, nor in any other window i open.

What exactly does zoom in when ALT+scrolling?

If you go into “Q” → “System Tools” → “Settings Editor” you should be able to go into “xfwm4” → “General” → “use_compositing” and toggle the value

After reading XFCE4 desktop zooming with the keyboard ~ Robert Basic, software developer making web applications better it might be possible to make a keyboard shortcut.

Edit: To toggle from dom0:

xfconf-query -c xfwm4 -p /general/use_compositing -t bool -T

… and you can use “Q” → “System Tools” → “Keyboard” to add a “Application Shortcut” to that command.


Thank you very much, this was exactly what I was looking for you saved me! :slight_smile:

We don’t know what exactly saved you, so please mark the post that saved you, as a solution so it could help other users too.

Turning off compositing is a hammer.

To turn off zoom you need to turn it off in Xfce - that’s a setting
under SystemTools ->SettingsEditor->xfwm4.
Clear the checkbox.

If you want to keep the zoom facility generally, you can change the
keyboard -

generally, if you want to use a shortcut in a qube, you need to make
sure that it isn’t already captured by Xfce in the guiVM.
(The equivalent can be done in KDE of course.)

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.