How to set trayicon_mode = "border1";?

I’ve tried editing guid.conf (depreciated) and I’ve tried setting qvm-features bit it doesn’t work.

Anyone have any ideas?

Why not use a GUI for that?

Menu → Qubes Tools → Qubes Global Settings → Tray icon style.
Choose the preferred one and reboot the system.

1 Like

Thank you, not sure how I missed that.

However, do you know how to set multiple values?, For example before you could have tint and border1? Through the GUI it seems you can only have one or alternatively setting it for VM specific

Currently this has to be done on the command line:

qvm-features dom0 gui-default-trayicon-mode tint+border1

(Replace dom0 with the GuiVM if you have one.)

1 Like

Unfortunately that doesn’t work for me.

I’ve got 4.1 default config so shouldn’t have a GuiVM. So dom0 should be the target. It doesn’t change the icons and using qvm-featured this way doesn’t change the global settings on the GUI either

Not sure what I’m doing wrong

Did you restart the VM where the icon originates?

Strange. What’s the output of just: qvm-features dom0

It was my fault. I needed to restart without saving session. I logged out first then shut down which didn’t update. Then I reapplied the CMD, and restarted and it’s worked.

Thank you very much

1 Like

For others who might be interested in this, from guid.comf itself

# EDITING THIS FILE WILL NOT HAVE ANY EFFECT! It is not read by the GUI daemon
# anymore, and is left here for reference only. To configure the GUI daemon,
# use qvm-features (see ‘man qvm-features’ for details).

Can you do this only for one specific VM?

Never mind replacing dom0 with VM worked