How to scale the Qube Manager?

I set Xft.dpi: 192 at /etc/X11/Xresources in dom0, but the Qube Manager didn’t scale accordingly with everything else. When I hover the mouse cursor over the manager, it becomes smaller. Does anyone have a solution for this? I couldn’t find anything in the docs.

I’m using Qubes OS 4.1.1.

I had the same issue. Global scaling for tiling window manager - #9 by vxc


edit: I removed gnome-settings-daemon and text is appearing larger now.

For the cursor, you may want to add Xcursor.size: 32 to .Xresources.

Thanks for the reply.

I have no gnome-settings-daemon installed in dom0.

What resolution and frame rate are you using?

I thought gnome-settings-daemon came by default with Fedora in dom0. Are you using a different distribution?

What is the output of xrdb -query | grep dpi?
You may find this article helpful if you haven’t used it yet: X resources - ArchWiki

Personally I place the file in my home folder ~/.Xresources, but I don’t see why it wouldn’t also work in /etc/.

3840x2160 at 60Hz

I’m using Fedora. When I used the command sudo dnf remove gnome-settings-daemon
I got
No match for argument: gnome-settings-daemon No packages marked for removal. Dependencies resolved. Nothing to do. Complete!

The output of xrdb -query | grep dpi is Xft.dpi: 99 which is weird since I’ve changed the dpi at Xresources.

try 1920 x 1080 60Hz 0r 30Hz and lets see!

Of course, but I’d rather want to run my monitor at 4k as its supposed to.

Just a test we are studying behavior that’s all

Did you merge Xresources? You may want to try creating ~/.Xresources instead and then merge. Also I am assuming you have already logged out and back in after creating Xresources. If you have not, then you should.

Here is another relevant article. The section for your desktop environment might be worth checking out.

Correct me if I’m wrong, but I don’t think changing resolution and especially refresh rate is productive for troubleshooting scaling.

Ok, so I did a bit of testing by removing the Xft.dpi: 192 from /etc/X11/Xresources and rebooting the PC. Nothing happened to the scaling after reboot, which means Settings Manager > Appearance > Settings > Window Scaling and setting the value to 2 did the trick for dom0 except the Qube Manager. Setting the DPI in Xresources works in the templates though.

When I use the command xrdb -query -all
I get
Xft.antialias: 1 Xft.hinting: 1 Xft.hintstyle: hintslight Xft.rgba: none Xft.dpi: 99 Xcursor.theme: Xcursor.size: 0 Xcursor.theme_core: 1
Do you know where the xrdb command is pointing to? When I merge it with current Xresources, it does merge, but after reboot it points to the default values above which I don’t know where it’s located.

Sorry for leading you astray. I’m not using a DE like xfce, so that’s why I am using .Xresources. In your case you probably want to use the xfce tools to do scaling. This picture guide might be helpful if you don’t want to read the arch wiki XFCE Hi DPI screens – Discovery. Keep in mind that qubes manager is a QT app, so you will need to set scaling for QT apps. QT_SCALE_FACTOR is the environment variable you are probably looking for. It would be best to read this section HiDPI - ArchWiki.

1 Like

I followed the instructions in the first link you provided and it worked! Thanks for your time and help.