How to Install Windows in Qubes 4.1?

You have guide how to build and install QWT on @jevank github: GitHub - tabit-pro/qubes-windows-tools-cross: Qubes Windows Tools build with mingw, wine and qubes-builder

Before that, You have to install Windows in HVM. It is really straightforward. Yo have to create Qube as standalone not based on any template. Check “Launch settings after creation” and in the settings give the Qube 50GB of System storage space. In Advanced, uncheck (if checked) “include in memory balancing” and give qube 4096 MB of RAM. Then switch kernell to none, and finally run from ISO located in some other qube downloaded from MS website. Then installation is like on normal machine. You only have to be sure that You installing it on System partition (first on list).

After installing You can install QWT using installer from attached ISO (instruction how to attache on that github link)

Finally You can add some features flags to VM running commands in dom0:

$ qvm-features <YOUR_WIN_VM_NAME> gui 1
$ qvm-features <YOUR_WIN_VM_NAME> gui-emulated 1
$ qvm-features <YOUR_WIN_VM_NAME> qrexec 1
$ qvm-features <YOUR_WIN_VM_NAME> stubdom-qrexec 1
$ qvm-features <YOUR_WIN_VM_NAME> audio-model ich6

also there is a hint in some guides to increase qrexec timeout but I don’t know if it is still necessary.

$ qvm-prefs <YOUR_WIN_VM_NAME> qrexec_timeout 300

1 Like

Little correction

it is not necessary, it will be set automatically after installing QWT.

This prevents from breaking Windows updates applying or disk checks.


Thanks for your simple guide

After installing Windows as standalone successfully
I have followed these steps : (according to this guide ) GitHub - tabit-pro/qubes-windows-tools-cross: Qubes Windows Tools build with mingw, wine and qubes-builder

  1. Setup build environment
    In Dom0 :
cd ~
sudo dnf -y install git make mock

outputs :
[BBV@dom0 ~]$ sudo dnf -y install git make mock 
Qubes OS Repository for Dom0                    1.5 MB/s | 3.0 kB     00:00    
No match for argument: git
No match for argument: make
No match for argument: mock
Error: Unable to find a match: git make mock

What is wrong here ?!

You should probably do that on some Fedora based VM not in dom0. I think dom0 may not have standard Fedora repos added by default.

I did it in new appVM based fedora template :

And I have problem here :

[user@windows-fedora ~]$ git clone fatal: destination path 'qubes-builder' already exists and is not an empty directory. [user@windows-fedora ~]$ cd qubes-builder [user@windows-fedora qubes-builder]$ make install-deps make: *** No rule to make target 'install-deps'. Stop.

[user@windows-fedora qubes-builder]$ make remount make: *** No rule to make target 'remount'. Stop.

[user@windows-fedora qubes-builder]$ make BUILDERCONF=example-configs/qubes-os-master.conf COMPONENTS=builder-rpm get-sources make: *** No rule to make target 'get-sources'. Stop.

[user@windows-fedora qubes-builder]$ make BUILDERCONF=example-configs/qubes-os-master.conf BASEURL= GIT_PREFIX=tabit-pro/qubes- INSECURE_SKIP_CHECKING=windows-tools-cross COMPONENTS=windows-tools-cross get-sources make: *** No rule to make target 'get-sources'. Stop.

You have that folder and it’s not empty, so You can’t clone to it. Remove it and try again.

1 Like

How ?

rm -rf qubes-builder ?

1 Like

I have a strange problem after following the previous steps … And staring Windows 10, it is shutting down …

What is the problem

Hello, I have followed all the guide to compile and install QWT on 4.1, but when I try to copy any file to Windows VM, it give me the error Failed to execute **qubes.Filecopy**

Should I modify the qubes-rpc policy? I made many try without understand the problem.
It could be because I’ve set qvm-prefs <VMname> default_user <username> as I read in another guide? I haven’t done it on 4.0 and everything worked fine, but I don’t know how to change it back.
Thanks in advance

Ok, I had not install it in dom0 as you explain here . So the only way to make it work is install xen-hvm-stubdom-linux-full package? In any case, also with the package installed it give me the same error.
Also, sorry for write here and not in the dedicated post, I didn’t know it

Just reading this after searching for how to create Windows Qube…
What exactly do you mean by this? Are you saying to download Windows 10 using another Qube, and run it through the newly created standalone Qube?

Yes. There are up to date guides right now on github. Contents/ at master · Qubes-Community/Contents · GitHub

1 Like

I built mine without any terminal needs, not sure why it worked but it does, have done it several times.

  1. Start an existing vm, make sure it has enough personal space to hold the windows iso (> 6GB)
    1a. Go to windows website and download an iso (I used win10)
  2. Qubes tools > Create new VM
  3. Name your qube and pic a color
  4. Type: standalone
  5. Template: none
  6. Initial RAM: I used 2000, but 4096 mb would a good choice
  7. Check the box “install system from device”
  8. Select " from file in qube" and pick the qube you downloaded the windows iso into (I used a windows 10 iso). the “…” will help you navigate to the iso itself. Click on the windows iso, the process starts.
  9. The qube creates and now you are in windows. God help you.

Oh, I almost forgot, you have to make the qube size at least 50 and personal size at least 20. This is done in “Qube settings” Trial and error…