How to debug system freezing? (Please help)

entire system froze […] when using kernel version 5.4.x … never with v4.19.x […] I can no longer reproduce this with the latest 5.4 kernel on the T430.

Well, it took longer… but it’s still happening. Ran the salt-based update while also shutting down a large HVM. Then it happened: total freeze incl. mouse … everything. There is nothing in journalctl. Just “— reboot —”

Switching back to 4.19 kernel.

I now tried Qubes 4.1 RC1 and the system works flawlessly - not a single freeze anymore (with Samsung 870 EVO).

1 Like

how do you switch back to kernel 4.19?

I just updated at T540 and lost the wifi networking also, freezes on the desktop,

00:17.0 SATA controller [0106]: Intel Corporation Q170/Q150/B150/H170/H110/Z170/CM236 Chipset SATA Controller [AHCI Mode] [8086:a102] (rev 31) (prog-if 01 [AHCI 1.0])

is my Samsung Evo 8xx series , also freezing

kernel 5.10.76-1

rc2 I believe


how do you switch back to kernel 4.19?

sudo qubes-dom0-update kernel-419 kernel-419-qubes-vm

Then reboot and select in grub.

1 Like

hmm, it can’t find that package
and don’t really see anything with
$dnf search kernel

hmm all this time with my Evo 840 I’ve not been using any TRIM

per lsblk there are 0 's for the parameters instead of a “non-zero”

somehow not sure I want to mess with dom0, unless there is some standard for fstrim in dom0?


That’s because dnf search in dom0 can only see what’s already installed, it doesn’t have access to the internet and cannot download any catalog.

The command I posted works in R4.0 … if you are on R4.1 I am not sure kernel 4.19 is still supported there.

1 Like

fwiw, i’m on the latest 4.1 stable, just had to hard reboot 4 times, after system froze repeatedly, no idea why…

however, without any dom0 updates, previous to this it was up for 8 days straight, not seeming so ‘stable’ to me yet

still no idea how to trouble shoot

I have a Samsung 870 EVO and I am experiencing freezing and big performance issues too. Perhaps this is the issue I am also having.

Has this issue completely resolved itself?

Yes, I’ve never seen a freeze again since I switched to Qubes 4.1 and BTRFS. I didn’t test whether I would have actually needed BTRFS, so maybe just using Qubes 4.1 would have worked already.

1 Like