How do i update whonix-gs and ws-16 in Qubes 4.1? And which template should i have when using debian as default?

How do i upgrade whonix gs and ws -16 in Qubes 4.1 exactly step by step?

And what templates should i have if i run qubes with debian as the ground template? I choose debian when setting up qubes in the install meny.
I messed them up after reading some issues with on how to update whonix just now…

I have this error right now:

Updating whonix-gw-16

Error on updating whonix-gw-16: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’, ‘–targets=whonix-gw-16’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’]’ returned non-zero exit status 20.
whonix-gw-16:

        ID: update
  Function: pkg.uptodate
    Result: False
   Comment: E: Release file for tor+https://fasttrack.debian.net/debian/dists/bullseye-fasttrack/InRelease is not valid yet (invalid for another 1h 35min 13s). Updates for this repository will not be applied.
   Started: 14:24:44.907295
  Duration: 3668.091 ms
   Changes:   

        ID: notify-updates
  Function: cmd.run
      Name: /usr/lib/qubes/upgrades-status-notify
    Result: False
   Comment: Command "/usr/lib/qubes/upgrades-status-notify" run
   Started: 14:24:48.579178
  Duration: 3300.333 ms
   Changes:   
            ----------
            pid:
                1838
            retcode:
                100
            stderr:
            stdout:

Summary for whonix-gw-16

Succeeded: 0 (changed=1)
Failed: 2

Total states run: 2
Total run time: 6.968 s

Updating whonix-ws-16

Error on updating whonix-ws-16: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’, ‘–targets=whonix-ws-16’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’]’ returned non-zero exit status 20.
whonix-ws-16:

        ID: update
  Function: pkg.uptodate
    Result: False
   Comment: E: Release file for tor+https://fasttrack.debian.net/debian/dists/bullseye-fasttrack/InRelease is not valid yet (invalid for another 1h 30min 39s). Updates for this repository will not be applied.
   Started: 14:29:18.489082
  Duration: 4827.094 ms
   Changes:   

        ID: notify-updates
  Function: cmd.run
      Name: /usr/lib/qubes/upgrades-status-notify
    Result: False
   Comment: Command "/usr/lib/qubes/upgrades-status-notify" run
   Started: 14:29:23.320199
  Duration: 3784.066 ms
   Changes:   
            ----------
            pid:
                1843
            retcode:
                100
            stderr:
            stdout:

Summary for whonix-ws-16

Succeeded: 0 (changed=1)
Failed: 2

Total states run: 2
Total run time: 8.611 s


And the templates looks like this:
The default-mgmt-dvm used to have debian 11, and now has fedora-34. Still error…

whonix-ws-16-dvm have fedora 34 now, used to have debian.

How do i update whonix exactly in qubes 4.1? Any step-by-step guide? It don’t work by default… So someone must have solved it? Or is it an issue still? Solved? I searched but missed the answer… Solution. Thanks!

run this in dom0.
to update workstation :

qvm-run --pass-io -u user whonix-ws-16 “upgrade-nonroot”

to update gateway :

qvm-run --pass-io -u user whonix-gw-16 “upgrade-nonroot”

Thanks! Can i switch the templates to debian also? Instead of fedora… I think the fedora releases are too short, and new ones releases too fast. One version could be worked on a couple of years in my opinion. Or one release all the time would be easiest perhaps… V1.87654576 :wink:

as far i remember there’s a known bug in 4.1 that you can’t use debian as networking to download templates and i haven’t tested it again. I don’t use debian as default (mgmt / networking, etc). but you can try.

Nah. Did not work i got this error:
Hit:1 tor+https://deb.debian.org/debian bullseye InRelease
Hit:2 tor+https://deb.whonix.org bullseye InRelease
Hit:3 tor+https://deb.debian.org/debian bullseye-updates InRelease
Get:4 tor+https://fasttrack.debian.net/debian bullseye-fasttrack InRelease [12.9 kB]
Hit:5 Index of /r4.1/vm/ bullseye InRelease
Hit:6 tor+https://deb.debian.org/debian-security bullseye-security InRelease
Hit:7 tor+https://deb.debian.org/debian bullseye-backports InRelease
Reading package lists…
E: Release file for tor+https://fasttrack.debian.net/debian/dists/bullseye-fasttrack/InRelease is not valid yet (invalid for another 1h 23min 26s). Updates for this repository will not be applied.

Why not? Debian is the best linux version out there right? One of the most secure. I don’t wanna use fedora… But i might need to in Qubes though… Is it as secure even as debian?
Are both 100% open source (FOSS)?
I guess i could get used to dnf install instead… I just like debian also though…
What is the reason the Qubes team even prefer fedora over debian? Is it better or what… More support or something i don’t know about… Or that it’s their personal taste of OS and that’s why?
Just curious.

try apt clean if it doesn’t work reinstall whonix template.

I use debian for long time before using qubes, actually that i use many different template for anything, so i couldn’t say i’m just using fedora :slight_smile:

the main reason is hardware support as far i remember.

How do i use apt clean? I tried sudo apt clean in xterminal in both gs and ws. And in debian 11 template. Did not work in dom0.

How do i reinstall whonix? Any step by step guide? I can search one up also… Some quick easy guide… Do i need to use fedora, or can i use debian also, or will i get the same update error in qubes? Thank you!

Ok, hardware support… Well, that could be implemented in debian also right… But thanks for the answer. And both are foss right? 100% open source?

edit:

Which of these is the answer im looking for also?

I just need quick ways to update qubes… Some easy commands if possible, without needing to search them up… But i get it’s testing and allot of work with an experimental OS. :slight_smile:
I like it… But it’s kinda frustrating sometimes when i don’t understand linux as well as others on here. :wink:
Updating the OS is one of those things… “the qubes red icon update of death” Kidding. Better then the bluescreen of death though in windows. :wink: oh well… will try reinstalling whonix…

How do you reinstall whonix? I tried one thing it did not work for me…
I have not reinstalled properly, i still get the:
Updating whonix-gw-16

Error on updating whonix-gw-16: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’, ‘–targets=whonix-gw-16’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’]’ returned non-zero exit status 20.
whonix-gw-16:

        ID: update
  Function: pkg.uptodate
    Result: False
   Comment: E: Release file for tor+https://fasttrack.debian.net/debian/dists/bullseye-fasttrack/InRelease is not valid yet (invalid for another 1h 30min 12s). Updates for this repository will not be applied.
   Started: 16:59:46.232151
  Duration: 4157.518 ms
   Changes:   

        ID: notify-updates
  Function: cmd.run
      Name: /usr/lib/qubes/upgrades-status-notify
    Result: False
   Comment: Command "/usr/lib/qubes/upgrades-status-notify" run
   Started: 16:59:50.398830
  Duration: 3280.896 ms
   Changes:   
            ----------
            pid:
                4204
            retcode:
                100
            stderr:
            stdout:

Summary for whonix-gw-16

Succeeded: 0 (changed=1)
Failed: 2

Total states run: 2
Total run time: 7.438 s

Updating whonix-ws-16


Could you give an detailed explanation please on how i can install and update whonix in qubes 4.1?
Like the right commands and so on?
It’s easier for you computer experts and coders out there to fix your qubes issues then for me not having much experience in unix…
Thanks again

are you still using debian as default networking ? if yes change to fedora.
delete whonix-ws-16 and whonix-gw-16 from qube-manager include, whonix dispvm, sys-whonix, etc. then run in dom0

qvm-template-gui

then choose to install whonix

sys-whonis says updatevm is using it… I deleted a bunch of other stuff… How do i remove the updatevm settings so i can delete sys-whonix?
edit: nevermind i just found the option in global settings menu…

in qubes tools > qubes global settings.
UpdateVM change to sys-firewall

Thanks… I removed the whonix-ws-16 in qubes-gui kinda by mistake… I thought it would clean the system, not remove the option in the menu. How do i add it in qvm-template-gui again? So i can install everything…
If there are issues with updating qubes… I’m trying one more time, if it does not work i need to reinstall Qubes (using fedora instead of debian if debian is not supported) and having wasted allot of time setting things up nicely in my setup just because some update did not work…
Thanks for the help. Kinda frustrating when i’m messing around with stuff i don’t know how it works really…
An working update would had been nicer… But i get it’s a complicated OS and that it’s hard to update Qubes…

are there any issue in qvm-template-gui ? you mean that you can’t install whonix or ?
honestly that this happen since 4.1-rc1 before that everything is just work, and even this is not critical like debian sid did (kernel panic), it’s still ruin my daily use :slight_smile:

hehe i accidentally removed the option… I thought it would remove stuff from the machine… So i need to add it… Yeah i mean. I’m not great with technology, so if a update don’t work it messes up stuff for me…
And if i mess up my system even more you know as i always do… Most often… Then i need to re-install and start over again…

I think i have installed qubes 10 times… maybe 12 overall or more. 15 :wink:
Most often because i messed up stuff…More then the updates not working… It’s experimental. But i guess i have learnt some stuff so it’s not all a waste. :wink:
Great OS, but complicated for medium users! That’s all.

I’m more than that, especially when creating guide on my pinned post.
then reinstall is the fastest solution, just use fedora as default system-related. you could use debian for app.

true… fedora should be as secure and open source… I could just use that and avoid this again being stubborn wanting debian. :wink: thanks for the help. A fresh install is needed anyways. :wink: Peace out