How do I rescue a VM that lost many of the qvm tools?

I tried to install inkscape on my vm.

The VM is based on: debian-11.
It is a: StandaloneVM
Installed by RPM: No
Allow fullscreen: Allow
Allow UTF-8 window titles: allow
Qubes OS version: 4.1 (R4.1)
Kernel: 5.16.18-2.fc32.qubes.x86_64

Here is my dotfiles that I used so you can get an idea of what I had installed before hand:

I have run into this issue before after trying to install qemu and pip3.

Through the Qubes manager I was able to open a terminal.

I went into /usr/bin and listed the qvms tools.

It turns out that only qvm-convert-img and qvm-convert-pdf remain. All the other ones are gone.

I did apt remove inkscape… But it seems the damage is still there.

Is there a way for me to re-install the utilities that Qubes OS needs inside my VM?

The reason is I have a bad feeling that if I restart now I won’t be able to get back into the terminal. Because I have done it in the past and I got this error:

[Dom0] Error starting Qube!
daemon[21809]: qrexec-daemon.c:296:init: Wainting for VM’s qrexec agent.

…2022-07-22 18:35:24.748 qrexec-daemon[21809]:qrexec-daemon.c:135:sigchld_parent_handler: Connection to the VM failed

I am guessing that whatever Dom0 needs to access my VM is still in memory in my VM running.

So is there some ways to rescue my VM and maybe the other ones I have?

Also why would it do that after: sudo apt install inkscape

It doesn’t make any sense because I installed it in another VM without any issues.

Thank you in advance.

Maybe you can try to revert the VM state?

Here’s a documentation about this:

1 Like

Check out this thread:

Thank you @DVM it worked for one of my VMs.

But I tried to installing :

sudo apt-get update
sudo apt-get install -y

But again it made all the windows of the VM disappear and the many of the qvm commands in /usr/bin

The only one that are left are: qvm-convert-img and qvm-convert-pdf

Why are the other commands deleted?

Something strange is going on.

This was done in a fresh new VM based on debian-11 again using kali linux repo.

I did not do anything else in that VM.

The only other thing that was installed is the basic in my Makefile:

There seems to be a bug…

The only difference from the default debian-11 template is the kali linux repository. Maybe a package want to delete a dependency which is needed by the qubes core packages?

Do you have any log from apt-get to share? Try to do it again, remove -y from the command and share the whole output.