Hide appvm systray icons is broken in 4.2?

I can’t get the systray to hide the appvm icons, unless I log out.

When I log in, the icons are added to the systray outside the hidden area. I log out and back in, now the icons are inside the hidden area, and need to click the show button to see then.

Is there something I need to do to hide the icons without having to log in twice?

It’s the systray plugin, properties > systray icons > vmapp command option I’m talking about.