Help runnig R4.2 on my Virtual Box

Tried mounting Qubes R4.2 on my VirtualBox, but always gets stuck after finishing installation & reboot.
I get a teal screen with some options, but no response whatsoever - it freezes out.
Anyone have a tested solution/ workaround please respond.

Info needed.

→ What is your host OS for VirtualBox?

→ Hardware you are running on.

→ Virtualbox settings for that VM. In particular, the CPU settings you are using. Others would be helpful as well.

→ Virtualbox logs, if you have setup this up.

latest VB on Win11 MSI Vortex G25 w 32GBRAM, and allround NVMe.
VB 2 CPU cores, GPU acceleration enabled, 4096 RAM 500GB fixed disk, Bridged network

From the page “System requirements”, the minimum RAM seems to be 6Gb:

– that should be simple to correct as a first test. :slight_smile:

Doesn’t hurt to try anyways.
From what I remember the 4GB was the minimal…

From the System requirements page - in the “Minimum” section:

    CPU: 64-bit Intel or AMD processor (also known as x86_64, x64, and AMD64)
        Intel VT-x with EPT or AMD-V with RVI
        Intel VT-d or AMD-Vi (also known as AMD IOMMU)

    Memory: 6 GB RAM

    Storage: 32 GB free space

Just tried with just over 6GB RAM and got a critical error in the VB, so got the same non-responsive teal screen.
-Don’t really know what to do next.
If you have the settings for a successful install on VB - I’d appreciate the settings, so I can compare and correct anything if set up wrong.

i aggree you can test it with 4gb ram, but i believe you still have a lot unused right ?
never try with virtual box, but here’s for vmware

10gb ram, 4 vcpu, uefi, 60gb storage, vtx vtd, you are good i think.

Thanks for the help,
Tried settings, but it sent me back to reinstall, which I’m going through as fast as possible right now.
Left it alone for 90 minutes and it froze up before rebooting (reboot request shows).

Try legacy BIOS for the VM.

Also, when you get error messages, take a picture of them and post
it in your updates. ‘got a critical error’ is not very useful.

Post the exact settings you are using for your guest CPU.
From the three tabs: ‘Motherboard’, ‘Processor’, ‘Acceleration’
shown in the attached image, as an example.

Tried it - did not work.
Tried running the 4.1.2 version, and go this message:

Check and my Virtualization is enabled, and my processor (core i7-8700) supports the IOMM, as required. At this point I really don’t know what is wrong with it.
I even reinnstalled the VB software, and new Qubes machine to try as a workaround.
Nothing going so far.

Updated state:
Enabled hyper-v (win features), and got the following screen:

Got into the screen which seems to end with the vlm option.
approved it once, disapproved it another time.
-It doesn’t seem to matter - the machine doesn’t move to another screen after hitting “done”.
-Installed the free VMware player version (17.02), and tried to get it to run on it.
It claims not to support the needed components (the software this time??) -and shut itself down.

Make sure the following settings pointed to at this page
are checked. Show us the options you are using for VMware player as well

IOMMU is needed for qubes to work correctly, even though you technically can click through the error
on the screen. You are switching between multiple different virtualization solutions, so whatever you are
using, ensure that is enabled. Wouldn’t hurt to check on your host BIOS that it’s enabled there too.

IOMMU as I understand it is a matter of supporting HW CPU. Mine is core i7-8700 which supports it.
Enabling the Hyper-V in windows, somehow enabled the restart at the end of the installation, but something is stuck when it is time to finish the configuration and run it.
Before enabling the hyper-v, it would get stuck after restarting, and not finish the installation, though the virtualizaion in the BIOS was on.
-It seems like I have to try and go through the list of disabled windows features and work out which is blocking one of the abilities enabled in the BIOS.

it is called nested virtualization, try searching again, i did it in the past with vmware.

It seems that enabling hyper -v (win features), prevents VB to use nested-v. Only one virtual process is able to use it.
I have disabled it, and am going to try and see what’s in the BIOS while restarting for changes to take effect…

I did enable nested - it seems that there is a script that has to be followed to enable a specific VM to become a nested one
-I found how to do so, and did, but got to the same initial setup screen that will not shift when “done” to anything.
–unninstalled vmware free layer and hyper-v
–Enabled in BIOS also VT-x
–Powered up R4.1.2, and just tabbed to sections I did not have access to, and click “done”,
-It warned me that I might not get all the functionality, but it actually worked !! -I got it to run.
++Now I have to see how to set it up correctly and use it.
–Cheers guys for the support.
You got me to discover that nested thingie script, and that the BIOS part was only partially enabled.

1 Like