Help Configuring a Wifi Adapter

I need help getting a TPLink AC 600 adapter to work in Qubes. When I moved to a new room in my house, I decided it would be more convenient to use wifi instead of ethernet to connect to the internet on my desktop PC. I was able to get dom0 to recognize the adapter. I was able to select the available networks from a list. And I was able to do a Qubes update using that wifi adapter. However I could not connect to the internet in any of my App VMs nor in sys-net. Do I need to install a TPLink driver in sys-net or in a template?

In the sys-net Devices tab, is the adapter selected? If you can select available wifi networks then I think sys-net is working correctly. On another note, you could also create another sys-net just for wireless to separate wired from wireless.

I have a broadcom adapter that isn’t compatible. It doesn’t work at all so your case seems like just a setup problem.

My adapter does not show up in the Devices tab.

Hmm… I don’t understand how you can select available networks if it’s not there. My adapter is listed in the Devices tab but the tray icon does not have any wireless connection availability.

I was able to select my wifi in the network tray icon using this:

  • open Qube Manager → sys-usb → Settings → Services, add network-manager, confirm with OK.*

Reboot sys-usb.

… but I could not get the adapter to appear in the devices tab nor connect to the internet in any of the app VMs

Are you using R4.1? I’m on R4.0 but I recall 4.1 had the option to combine sys-net and sys-usb.

In the Devices tab of sys-net, it should appear in the Selected section, one entry for ethernet controller and the other for wireless. It might not be named as TP Link.

I don’t think Services > network-manager does anything unless your hardware is first available in the Devices tab. I would think the os should be able to identify your hardware but even then it doesn’t mean it’s compatible.

How do I determine the version?

Qube Manager > About > Qubes OS

The part I don’t understand is dom0 updates uses sys-net + sys-firewall + sys-whonix. I don’t understand then why AppVMs can’t connect.

But I ran across a situation where I was using a minimal template and couldn’t get interent access on the corresponding AppVM. I didn’t install the qubes-core-agent-networking package because I assumed sys-net would handle it. Wrong. I also needed to install that package in the minimal template. If you’re using the default templates, this isn’t a problem - unless you accidentally removed qubes-core-agent-networking or qubes-core-agent-network-manager from debian-10/11 or fedora-32/34. But if you did that your sys-net wouldn’t work and dom0 wouldn’t update.

Hi @bill

… but I could not get the adapter to appear in the devices tab nor connect to the internet in any of the app VMs

In the devices tab PCI devices are available. Your WiFi adapter is clearly a USB device, which means you need to use sys-usb also as your sys-net. This is easy:

[dom0] qvm-prefs sys-usb provides_network true
[dom0] qvm-prefs sys-firewall netvm sys-usb

Thanks! That worked.

So if I want to revert back to the old setup would I use:

[dom0] qvm-prefs sys-usb provides_network false
[dom0] qvm-prefs sys-firewall netvm sys-net

Yes.

Actually you could leave the provides_network on. So if you want to use the Ethernet card (sys-net) you point sys-firewall to sys-net and if you want to use the WiFi you point it to sys-usb.

Or you could go all in and assign your Ethernet PCI card to sys-usb too, in which case you would always use sys-usb also as a sys-net replacement. You might have noticed that the installer even offers to have sys-net and sys-usb be one qube for that exact reason.

Of course it’s better to keep USB and net isolated from each other, but this particular compromise doesn’t come with too many downsides. Yes, if someone plugs in a malicious USB device it does have the ability to use network and if you have at the same time some other USB stick with confidential data plugged in, that could be exfiltrated. Just be aware of this possibility.

1 Like

Sure. I understand the possible security risks.