Heads HOTP invalid error - Nitrokey pro 2

I’m new to Linux and Qubes - I’m having the HOTP error show when booting up qubes 4.1. I ran a backup and foolishly saved the backup file to dom0; the backup did not complete as I didn’t have enough space which also meant when I logged out and tried to boot up again it wouldn’t. I had to boot from a USB, mount dom0 and delete the backup file. It booted up ok but the HOTP error comes up. I ran a checksum update and verified clock drift wasn’t the problem. I also ran the option to check the TOTP/HOTP this ran but didn’t give me a message of any kind so am unsure what it did, if anything?

Any suggestions greatly received!?

From your report here, it seems that /boot ran out of space, and that Heads wasn’t able to update hotp counter file to match the dongle’s.

If TOTP matches, you could simply reseal HOTP/TOTP from Heads Options menu. That will prompt for your GPG admin pin to reseal measurements, but most importantly, writr the counter file under kexec_hotp_counter which couldn’t be updated because /boot was full.

Hope that answers your question.

1 Like