HCL - Lenovo Thinkpad L14 (gen 3)

‘unknown’ (Enabled in UEFI but not detected)
brand: |
model: |
bios: |
R1XET44W (1.26 )
cpu: |
12th Gen Intel(R) Core™ i7-1260P
cpu-short: |
chipset: |
Intel Corporation Device [8086:4621] (rev 02)
chipset-short: |
gpu: |
Intel Corporation Device [8086:4626] (rev 0c) (prog-if 00 [VGA controller])
gpu-short: |
network: |
Intel Corporation Device 51f0 (rev 01)
Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 05)
memory: |
scsi: |

usb: |

  • works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    PC runs well. Battery lasts a few hours. Bluetooth works after installing Blueman. No suspend yet. Networking/Wifi works. Video works. See link below for steps I have taken to try and get suspend to work.
    credit: |
    link: |
    Resuming From Suspend Reboots The Laptop Instead (Lenovo L14 | i7-1260p)

Qubes-HCL-LENOVO-21C1CTO1WW-20230611-072549.yml (1.1 KB)

1 Like

As you may notice on the HCL above, I have the latest EXPERIMENTAL kernel installed. Everything that is working above worked on the standard release kernel. I installed the latest experimental kernel to try and get suspend to work. The latest kernel did resolve some issues relating to suspend, but it didn’t resolve them all, and it still doesn’t work as of now.

1 Like

Check older kernels, here @disp666 provides info that S3 is working for him with 6.10 kernel, but not newer ones.

My apologies for the delay @balko , I have been slammed at work but I wanted to make sure I thanked you for your comment since it resolved my issue. I can now suspend and resume on kernel 6.3.2-1 I tested several and this seems to be the only one that works so far.

1 Like

With kernel 6.3.2-1 installed on Dom0 I was having issues where my appVMs froze for a couple of minuets after resuming from suspend. I was able to resolve the AppVMs being frozen for a couple of minutes by downgrading the AppVM kernel (not the sys-vms or Dom0) to 5.15.103-1.

I did this in the qubes manager, by right clicking the appVM and clicking settings. On the “advanced” tab, choose the kernel version.

I also had to enable “linux s3” in the UEFI to get susepend to even work in the first place.

1 Like

Did I post this correctly for addition to the HCL list? @Sven

Also note that I did get suspend working by installing with current kernel. Using latest kernel broke suspend.

You did. I’m traveling. Will catch up soon.

1 Like

No worries and thanks.
Enjoy your travels.

1 Like

Thank you @majg for your HCL report, which is online now!

Your full report (comments) are linked. I shortened your remarks to “No suspend” because of the table layout and the rest of your remark being about things that work (important information).

Also your report was signed MAGJ while your user alias and previous report are @majg. … so I changed that too. Let me know if MAGJ was in fact intended.

1 Like

Thanks @Sven .

I just mistyped my username, so thanks for correcting.

Yes suspend works, but only on the 6. stable kernel.


Not anymore, right? Does 6.4.7+ work for you?