Having trouble with secondary SSD install

Hello Everyone

Read this Secondary Storage | Qubes OS
executed all steps up to

“Now, you can create qubes in that pool:” I didn’t create any new pools from the cli or clone and replace. etc

I’m stuck at :
sudo cryptsetup luksFormat --hash=sha512 --key-size=512 --cipher=aes-xts-plain64 --verify-passphrase /dev/sda

I get an error that /dev/sta doesn’t exist or access denied

I’m using latest stable release with all updates

Any suggestions?

I assume you mean /dev/sda doesn’t exist, not sta.
How does the new disk appear in the system? What’s the output from
ls /dev/sd*

ls dev/sd* returns

/dev/sda /dev/sda1

What do you mean by execute all setup?
That command is the first you have to execute.

And have a look at :


Then search your disk.

Hi 51lieal - I executed all steps up to creating qubes in the new logical volumes.

lsblk returns


I can say that your drive is not mounted, you have only /dev/sda there.

Well my cubes volume is mounted. I didn’t bother to list out all that stuff.

Do i have to specifically mount the new volume before trying to encrypt?

I tried sudo mount /dev/sta mnt
mount: /dev/sta already mounted or /mnt busy

And I can see that there is no mount point for sda using lsblk

what’s your qubes os disk id ? /dev/nvme0n1 ? if yes
is there any data on /dev/sda1 ? try deleting your /dev/sda1 first.

gdisk /dev/sda 

then run

cryptsetup  -h sha512 -s 512 -c aes-xts-plain64 -y -i 10000 luksFormat /dev/sda 

Yes QOS disk is /dev/nvme0n1. so i did what you suggested (thanks)

I still get the same error “Device /dev/sta doesn’t exist or access denied”

What do you mean by /dev/sta ?
Are you typo or what, just a single weird word would cause an error.

have you delete partition /dev/sda? Try checking your command again.

Or you can try adding secondary storage in qubes os rescue.

Faceplant time :roll_eyes: STA should be sda


THanks 51lieal!!

1 Like