GUI domain not starting


just installed Q4.1 and ticked the option for gui / audio domain.

However, there was no sys-gui when the installation finished. Instead I had an error related to PCI bus reset for my ETH network card, which prevented the sys-net from starting.

After having this issue fixed, I installed the fedora-34-xfce template and created sys-gui based on this template. Updated all templates via Qubes Updater. INext I issued the following commands:

sudo qubesctl top.enable qvm.sys-gui
sudo qubesctl top.enable qvm.sys-gui pillar=True
sudo qubesctl --all state.highstate

No errors encountered.
Tried to logoff / logon to change from dom0 to sys-gui. Been thrown back to the login screen.

Qubes-prefs default_guivm was still set to dom0. Changed that to sys-gui. Still the same result. When I try to login using sys-gui I see for several seconds the Qubes desktop background and than I’ tmhrown back to the login screen.

Switched default_guivm back to dom0.

What I’m I missing?

Thx in advance.