Google Meet on QubesOS - bad quality


I am very happy to use QubesOS which I already have for several weeks. But there are two problems that are of major concern to me.

One thing is related to Google Meet. I have qube based on Debian with Firefox ESR. This is the qube from which I run Google Meet in the web browser. It has initial memory 800 MB and max memory 8000 MB, with 8 VCPUs. It is included in memory balancing. And it has private storage max size of 2048 MiB (currently used about 700 MiB).

I have also increased sys-usb settings to be initial & max memory of 2048 MB, instead of default 300 MB. I have 2 VCPUs but I’ve tried more. It’s not included in memory balancing.

And the problem is that my video is “shaking” which looks very bad to other users of Google Meet that I talk with. So I need to talk without my video enabled.

What else can I try, other than increasing memory of both qubes and VCPUs of my qube?

I have good hardware, based on Lenovo T430, bought from Nitropad, with almost all paid hardware features that were available.

Thank you!


I’d like to turn this to question: if someone knows USB webcam that is fast and reliable with Qubes using typical browser-based online conferencing, please let me know, I’ll buy it.

Try to identify the cause. I’d check the webcam’s performance in another app on the same VM. If it’s fine, then the problem is Google Meet or Firefox ESR. Try a desktop webcam app or Chromium.

If it’s similar quality in all apps, then make sure you have the appropriate driver. Maybe you need a proprietary one? Then try in a qube based on another template.

If you are connecting your webcam to your debian qube via a sys-usb qube, try connecting the pci device directly to the debian qube.

I’m not an expert but provided there are decent linux drivers for the webcam, I think it should work just fine.

I have created new qube with default parameters (I mean 4000 MB as max memory and 2 VCPUs) and the video looks ok. But when I try to record a video, the ‘cheese’ application stops after about 5 seconds (video recording freezes).

Let me clarify one thing - this is camera built into the laptop, it’s not external one. I just thought that internally it uses USB anyway. Thanks!

@newqubesosuser canyou try, in that new fresh qube, installing VLC and then attaching the webcam to the Qube, then using /dev/video0 as input/capture in VLC.

does it look OK ?

Can you also check out the media/codec in that same running VLC and see whats showing for frame rate, display resolution and any dropped frame count

Basically what we are trying to ascertain is there a bottleneck on the USB input to the Qube, or / as well as a misconfig in V4L2 input.

Personally, my bet is on a “problem” in Firefox ESR running google meet (eg, deploy chromium in a Qube and see what happens then)

Sorry to horn in, but I would say that my first generation Logitech C920 does the best of the ones that I have tried. I have lesser webcams (some older generation Logitech, some built-ins on some laptops - not generally the best option) that work much more piecemeal. The newer Logitech C920 may not be truly equivalent to my older model, which means we need to buy one just to test.

I have experience with Zoom, Google Meet, a few other usages of webcam under Qubes (Webex or MS Teams trials, Indeed’s video conferencing offering for job interviewing). For example: Zoom most often works with the C920 without trouble, an older Logitech (C615) can sometimes work as well but it’s anything but effortless (I could post much about my experiences with several USB-connected digital cameras, I may post about it further someday). For Google Meet, I’ve had less issues even getting the C615 to work.

None of them have had quite the “shake” that is described by the main poster. USB device loadout might be useful to ask about - it isn’t like the webcam is isolated to just the camera & the host controller (I’d imagine) & that may play into the difficulties.

Have you tried Qubes Video Companion?
It works fine with my integrated webcam on my laptop.
Hope it solves the issue for you

Funny I just bought C920 and it’s totally useless, the Qubes USBIP stack totally destroys it. It works (badly) maybe 1/3 connects, then it just drops and dies.

This is not a priority for me, so I’m just waiting for Qubes Video Companion to iron itself out.

That would be perhaps to my point, mine is a much older product.

“Chicken egg”, “dance”, “timing”, this is not how I use computers :smiley:

If something doesn’t work, then I don’t use it, and use some other computer instead. Maybe in couple of years it will work.

I think it’s fair to say that the Qubes rpc over USB/IP is not the most optimal solution for video streaming. It works for block devices very well.

Technically, it has worked for me much more than that.

Don’t get me wrong! I know exactly what you mean with those descriptions, and I found them spot on. I’m just too old for playing with computers. I can tolerate some tweaking, but if something doesn’t work rock solid, I’m not using it.

1 Like

So I’ve created new qube and assigned twice as much memory as by default, i.e. 8000 MB RAM instead of 4000 MB. And I’ve installed VLC on qube. (But it uses around 2 GB RAM).

Then done ‘capture device’ with ‘video device name’ set as /dev/video0. The video looks fine. The quality is a bit bad but there are no ‘jumps’ in the picture, as on Google Meet.

Codec from ‘current media information’ shows for ‘stream 0’ the following value: 'Codec: Packed YUV 4:2:2, Y:U:Y:V (YUY2)" for location “v4l2:///dev/video0”. It says ‘video resolution: 800x448’, ‘frame rate: 15’ but shows no information about dropped frame count. ‘Statistics’ tab shows only zero values.

I’ve also tried:

sudo qubes-dom0-update qubes-repo-contrib
sudo qubes-dom0-update --clean qubes-video-companion

But the second command shows “Error: Unable to find a match: qubes-video-companion” (I’ve checked it for typos).

It looks like Qubes Video Companion is still being tested and isn’t in the contrib repo, despite what the github page says.

But if your picture quality is acceptable in VLC then I assume the problem is Google Meet or Firefox ESR. Does the video still jump if using Chromium? If you’re keen on sticking with Firefox, maybe try the snap it’s more up-to-date.

1 Like

Based on the VLC test, im inclined to agree. I have found the need to use chromium for things like zoom, gm etc.

Thanks. I have tried with Chromium and had the same problem. But I started wondering whether it’s really problem with the camera because I also noticed the occasional problems with the video of people I was talking with, not just mine. Also, I hear very short noise when this problem occurs. When I was showing my screen and accessing other tabs from the web browser (while sharing them) I didn’t hear that “click” noise.

May I ask you to answer, please? Or at least suggest me what more I should check/verify? This problem and the one with HP printer are the only two things that prevent me from using QubesOS as day to day operating system. Thank you!