Getting audio working in a Windows Qube


I am on Qubes 4.1 on a Librem 14 laptop. My audio works fine in any AppVM derived from the standard fedora template that came with Qubes. However, in my Windows Qube (running Win10 with the latest QWT installed) there is no audio device detected.

After a bit of searching around, the impression I have gotten is that getting audio in a Windows Qube would involve PulseAudio, and that I would need a designated Audio VM in order to get it working.

I was able to get a “sys-audio” Qube installed with the following command:
sudo qubesctl state.sls qvm.sys-audio

I have not been able to find any solid documentation explaining how I would go about linking this Audio VM to my Windows Qube. From what I have read I will need to start a daemon called “qubes-audio-daemon” as part of the solution, but I am not sure how to install this.

In summary my questions are:

  1. Has anyone setup a Windows Qube and gotten audio working with it, and if so how did you do it?
  2. How can I install qubes-audio-daemon and what should I do with it once it is installed?
  3. Is the sys-audio VM I installed a component of PulseAudio? If so, how is it that all my fedora VMs have audio which work fine without an Audio VM?

You don’t need sys-audio to have audio in Windows, you do however need to enable the audio-model feature, you can do that by running qvm-features nameofwindowsvm audio-model ich6. As for using Windows with sys-audio you can follow the steps from this post:

1 Like