Gaming Laptop No Sound Card

Hello, Qubes OS 4.1 rc1 manages to boot on my MSI GF66. It is a 11th Gen i5 with integrated intel and discrete nvidia graphics. The only issue is there is no sound. I have already tried updating to the latest kernel, installing alsa-sof, alsa-ucm, and editing modeprobe.d.



Hi Ryan,

I have a feeling that you might need to run sudo qubes-dom0-update alsa-sof-firmware in dom0, so try that (I have some Tiger Lake machines too, and that worked for me).

If that doesn’t work, any chance you could post the ouput of lspci here?

Redact any information you feel you need to. I’m mainly interested in what Audio components your machine has. That will tell us what you need to do to fix it.

I have already ran the command you mentioned. I can’t post my lspci here because I am having trouble copying and pasting from dom0 and I don’t know where to save screenshots. I am 99% sure my sound card is intel.

Multimedia Audio Controller: Intel Tiger Lake-H HD Audio Controller.(rev 11)

Nice laptop, too, by the way :slight_smile:

Try this:

lspci > lspci.txt
qvm-copy-to-vm <your-favourite-vm> lspci.txt

That’ll give you the output of lspci in a text file in your favourite Qube.

00:00.0 Host bridge: Intel Corporation 11th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
00:01.0 PCI bridge: Intel Corporation 11th Gen Core Processor PCIe Controller #1 (rev 05)
00:02.0 VGA compatible controller: Intel Corporation TigerLake-H GT1 [UHD Graphics] (rev 01)
00:04.0 Signal processing controller: Intel Corporation TigerLake-LP Dynamic Tuning Processor Participant (rev 05)
00:06.0 PCI bridge: Intel Corporation 11th Gen Core Processor PCIe Controller #0 (rev 05)
00:08.0 System peripheral: Intel Corporation GNA Scoring Accelerator module (rev 05)
00:0a.0 Signal processing controller: Intel Corporation Tigerlake Telemetry Aggregator Driver (rev 01)
00:0d.0 USB controller: Intel Corporation Tiger Lake-H Thunderbolt 4 USB Controller (rev 05)
00:14.0 USB controller: Intel Corporation Tiger Lake-H USB 3.2 Gen 2x1 xHCI Host Controller (rev 11)
00:14.2 RAM memory: Intel Corporation Tiger Lake-H Shared SRAM (rev 11)
00:14.3 Network controller: Intel Corporation Tiger Lake PCH CNVi WiFi (rev 11)
00:15.0 Serial bus controller [0c80]: Intel Corporation Tiger Lake-H Serial IO I2C Controller #0 (rev 11)
00:16.0 Communication controller: Intel Corporation Tiger Lake-H Management Engine Interface (rev 11)
00:17.0 SATA controller: Intel Corporation Device 43d3 (rev 11)
00:1d.0 PCI bridge: Intel Corporation Device 43b4 (rev 11)
00:1f.0 ISA bridge: Intel Corporation Tiger Lake-H LPC/eSPI Controller (rev 11)
00:1f.3 Multimedia audio controller: Intel Corporation Tiger Lake-H HD Audio Controller (rev 11)
00:1f.4 SMBus: Intel Corporation Tiger Lake-H SMBus Controller (rev 11)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Tiger Lake-H SPI Controller (rev 11)
01:00.0 3D controller: NVIDIA Corporation GA107M (rev a1)
02:00.0 Non-Volatile memory controller: Kingston Technology Company, Inc. Device 500c (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

Yep. This is the one.

Ok, here’s what you need to do.

  1. Add the following parameters to GRUB_CMDLINE_LINUX=... in /etc/default/grub:

  2. run sudo grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg

  3. Reboot, and you should have sound.

Let me know if you need anything explained further :slight_smile:


Yes it worked!

Thank You

Do you have any experience with sys-gui?

What in particular is causing you grief?

I don’t know where or how to install the NVIDIA drivers. Also using standard sys-gui can I just install the drivers in a standalone VM? Or does it have to be done in dom0?

I installed it using this guide:


Pretty much dom0. sys-gui is essentially “showing” you dom0 right now. That’s kind of how it works in a nutshell. (This is purely for gist of understanding, and the full Qubes OS documentation will give you a much better [and more accurate] understanding).

If you’re going to be doing GPU passthrough (You have a gaming laptop, I’m assuming you’re going to be taking the GA107M for a spin), probably a good idea to install the drivers in whatever VM you’d be passing it through to.

Even if I am just using sys-gui not sys-gui-gpu?

What are you wanting to do? I’m assuming you want to play games…

Yes. At least try to.

Very nice.

I mean, you could try passing through your discrete GPU into a Windows HVM or a GNU/Linux HVM, and see what happens, but be prepared for it not to work…
(probably a good idea to make sure that whatever VM you’re passing it through to isn’t set to start automatically on boot, just in case you lose your display :stuck_out_tongue: )

There will definitely be a way, depending on how much you’re willing to get your hands dirty, but sadly, I don’t have an answer…

Gaming isn’t exactly high up on priorities of the use cases of Qubes OS…(yet…)

Sorry I couldn’t help you any further. But at least you’ve got your sound working! :slight_smile:

Its okay. Thankfully this laptop has two drives, so I can dual boot. Anyways thanks for your input and help.


Be careful dual booting. Security concerns aside (yes, they’re important, but not my main point), Windows does seem to like to annihilate GRUB without telling anyone, including when it’s on a completely separate drive. :angry:

Ok I will keep that in mind. Thanks.

The easiest for copying text from dom0 usually is (assuming the default xfce4-terminal):

  • right-click and use Copy
  • from the clipboard widget in taskbar select Copy dom0 clipboard

… and from there you can use the usual ctrl-shift-V to transfer the Qubes clipboard to your target VM.