Fullscreen standalone HVM in Qubes 4.1 without maxing HVM resolution?


I’ve just installed openSUSE Leap as a standalone VM. I’m trying to fullscreen it without setting it’s resolution to the same as in dom0 (Works fine when resolution is the same).

If I remember correctly in 4.0 it was as easy as editing the guid.conf file. From what information I was able to find in other topics, this file is no longer read.

Likewise that same topic stated that to do this now you have to run qvm-features like so:

qvm-features vm_name gui-allow-fullscreen 1

Or for global:

qvm-features dom0 gui-default-allow-fullscreen 1

I’ve tried both of these, including rebooting the VM and the entire system to no avail. Runing qvm-features dom0 or qvm-features vm_name shows that the commands have input the entries. Out of desperation I even tried all of it but replacing the dashes in the command with underscores. :laughing:

Can anyone confirm that it is still possible to do this in 4.1?

Have you tried using alt + f11 when the VM window is focused?

Yeah for sure. I forgot to mention that, sorry. :laughing:

I’ve also tried doing it by right clicking the VM window tile and then manually setting it to fullscreen. Works fine when the VM resolution is the same as dom0’s, but otherwise the fullscreen option is greyed out.

I’m using KDE by the way. :slightly_smiling_face: