Fullscreen application in multiple monitors possible?


For my work i using to connect Citrix Workspace App. I installed this app in my Work Profile and it worked perfectly. But when i want this app to use for multiple monitors that is something that don’t work.

The trick to getting this working on other Linux distributions is to put half of the app on one screen and half on the other screen and then click full screen. However with Quebes I only get it on one screen or the other.

How can I get this to use both monitors? Or is this a limitation of Qubes because they are all virtual environments?


So there is no possibility to run 1 application over 2 screens? It seems that an AppVM Application does not detect that there are 2 screens.

Didi you find a solution? I have the same problem with RDP. I did use Qubes for a long time and I did turn to multiple monitors only recently. Needing to switch back to another distribution for this would be a pitty. Creating it as an issue does get denied.

No i have no solution yet. I think multiscreen support in an AppVM is not possible. No body seems to know the answer on this question.

Dear All,

In QubesOS R4.0, I have two monitors connected to form a large screen made up by two monitors side by side. I would like to achieve what does work in Debian, for example, that is a fullscreen window covering the entire screen (i. e., both monitors). This is particularly useful in rdp-seccions using freerdp. It can be achieved using:

xfreerdp /multimon

This leads to a freerdp connection across multiple monitors at leaset in Debian GNOME.
In QubesOS R4.0 it does work in principle. A window as wide as the set of monitors does get created. However, the fullscreen feature does not work. As soon as one clicks fullscreen, the window gets confined to one of the monitors. Of course, I did allow fullscreen as described here: Full Screen Mode | Qubes OS And of corse, everything does work well with just one monitor connected. And yes, I do understand the security concept of normally not covering the entire screen but showng the window decorations including the VM color.

Is there a way to overcome that limitation? If “fullscreen” can be made to work across physical monitors in general, xfreerdp /multimon should work as well.

Thank you very much!

Michael Schefczyk

(@michael.schefczyk, I’ve moved your topic here as it seems the same issue)

Please be so kind to allow for any realistic possibility that this will be seen and answered at all. I was closed out from cubes issues by Andrew Dawid Wong. Of course, the issue is similar to what Gabbel posted, but nobody replied to his question. If I am now at the tail of a dead post, the likelihood of replies is practically zero, correct? Is there any positive advice?

Well, first consider that your use case is pretty uncommon. Since you said “In QubesOS R4.0 it does work in principle. A window as wide as the set of monitors does get created.” is really “fullscreen” so critical for you? I personally use a full screen sized xfreerdp window without “fullscreen” so I can see both KDE and Windows bars and have general better experience with the other opened windows.

Also consider please that your problem may not be directly Qubes related. I’m not currently using multi-screen setup but in my experience the default fullscreen behavior is maximize to current monitor. Maybe xfreerdp does some kind of workaround (since you use the /multimon option) for get the whole screen and not uses an standard fullscreen request.

Honestly if you can get a full screen sized window, I don’t think that “fullscreen” is so important. The experience is near identical and for me personally even better.

1 Like