Fresh Install - No templates, only have dom0 VM

I’m new to Qubes OS and Linux. I tried to install Qubes OS on a remote bare metal dedicated server through KVM but couldn’t get the installation to work. The host for my server installed the OS on their end for me. When I logged in to my KVM, the only VM I have in the VM Manager is dom0, and when I try to create a new VM i don’t have any templates, and because it’s dom0 I have no network access. I don’t know what the host did when they in stalled it but there’s literally nothing. I’ve tried reading through the forums to try to figure out what to do, and joined an unofficial discord for Qubes OS to try to find an answer. I’ve seen people talking about sys-firewall, sys-gui, sys-net but I have none of those, and I have no templates to choose from.

I found one thread where someone said to try

qubesctl top.enable qvm.sys-gui
qubesctl top.enable qvm.sys-gui pillar=True
qubesctl --all state.highstate

But I get an error message that says:

ID: fedora-34-xfce
Function: qvm.template_installed
Result: False
Comment: Failed to install template fedora-34-xfce. Additional info follows:
ERROR: [Errno 2] No such file or directory: '/etc/qubes-rpc/qubes.TemplateSearch'

I also got several errors due to UpdateVM not being set because I can’t create a VM and it’s set to default dom0. And it says in journalctl that it couldn’t find a connection to the host for the yum commands to install the needed template files.

Is there a way to possibly go back to the “Initial Setup” options for installing the basic VMs at installation without having to uninstall and reinstall the OS? I have no idea. Just grasping for straws.

Welcome to the qubes forum!

Not that i know of. If you did nothing with your installation so far, just reinstalling it would be the easiest solution normally. As you said that your server provider installed qubes for you, this might not be the best approach.

Please note, that the gui-vm is pretty much bleeding edge, and should only be used as an advanced user that is willing and able to troubleshoot. Not saying that you cannot do that, but as a new to linux user this is nothing i would recommend you doing. First get familiar with your system and how stuff works :).

So you have shell access to your qubes machine right? Over this channel you could try to get a template into dom0, start a netvm and load the rest.

Qubes does things especially unique with the package caching. I took a quick look on how this works and it seems, that you can just download your templates from the repo, somehow copy the rpm into your dom0 and install it that way. Never tried this, but it should work.

Also i want to add, that your system sounds pretty unique and is most likely not the most secure way to do things.

I just did a fresh install, and I still have no templates at all. During the initial setup phase, I had two options for Xen Hypervisor - 4.13.4 and 4.13.4.config or something like that and I chose the top one. Then it never gave me an option to choose the default Qubes settings that you see in the Installation Guide. I am so confused.

So once again, I have no templates, no sys-net, sys-firewall, sys-usb, sys-whonix, nothing. Just dom0

When I open System Tools > Packages > Search “Template” it shows four options with checkmarks next to all of them.

autogen-libopts-5.18.16-4.fc32 (64-bit)

So if its showing the packages and when I select them and click “Files” it looks like it shows all the different templates and everything. Is there something I need to run or something I can do to just like force it to open those or run those?

Okay well, I haven’t figured out how to install using the repo, but I did find a script that is supposed to install the VM from the salt files.

sudo qubesctl state.sls qvm.sys-net

But, a common denominator error that I am getting with trying to create the sys-net using that script, and with others from the link I attached is that I keep getting an error that says:

[ERROR] ====== ['present'] ======
====== stderr ======
/usr/bin/qvm-create sys-net --class=AppVM --label=red
app: Error creating VM: Got empty response from qubesd. See journalctl in dom0 for details

====== ['prefs'] ======
Virtual Machine does not exist!

====== ['service'] ======
[SKIP] Skipping due to previous failure!

The sys -firewall creation fails because of empty qubesd response, and failure to find prerequisite sys-net.

Also I still haven’t figured out where to get the qubes.TemplateSearch replacement

An issue/bug report has been created on GitHub and the Qubes OS team has marked as a bug that needs diagnosing. If any future users run into a similar issue as this one you can find this bug report to add any additional details or information you may have at the following link

Thank you so much to everyone who tried to assist me with this issue, I truly appreciate it!