Fedora 35 template updates break firefox DRM

Any one Else having issues playing DRM protected content in firefox for about the last week? I have Tried re-downloading the fedora 35 template and it fixes it but is missing the rest of the security updates … When i use the update tool and update it breaks firefox every time.

Did you try enabling DRM in settings?
You can easily find the toggle with the search bar once you open about:preferences

Yep I have tried that … below is the error messages from Firefox … i have tried to disable and re-enable both the Widevine and Cisco open H264 codecs in Firefox they both show enabled. but i cant play any video content with drm.

Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm

[Child 1163, MediaDecoderStateMachine #1] WARNING: Decoder=70a6f56fd200 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /builddir/build/BUILD/firefox-101.0/dom/media/MediaDecoderStateMachine.cpp:370

[Child 1163, MediaDecoderStateMachine #1] WARNING: Decoder=70a6f56fd200 Decode error: NS_ERROR_DOM_MEDIA_METADATA_ERR (0x806e0006): file /builddir/build/BUILD/firefox-101.0/dom/media/MediaDecoderStateMachine.cpp:3587

So I am guessing this is not a common bug at this point as i guess others would have chimed in… I am going to create a new qube from the updated template and see if i still have issues with drm on a fresh new qube with no existing data.

Thanks for looking.

Got it.

In case the problem persists, check the value of media.eme.enabled in about:config, and eventually try setting it to true.