Faster is not always better, or Qubes issues with SSD

Hello everyone!

Qubes documentation recommends using SSD. However I have been experiencing strange problems using SSD, namely:

  1. Auto-start VMs not always start. Yes, on a fresh installation using default settings, sys-net, sys-firewall and sys-whonix are set to auto-start by the installer, but what I experienced so far is:

sys-whonix never starts automatically (in both Qubes 4.0.4 and Qubes 4.1),
sys-net and sys-firewall rarely but sometimes did not start automatically (in Qubes 4.1 only).

  1. Qubes sometimes failed to set DPI as per user’s settings. The first setting I always change after installing Qubes is changing the default DPI and font size. In Qubes 4.0.4 it works without issue, but in Qubes 4.1 almost 50% of the time Qubes welcomes me with tiny font size on the 96 DPI desktop.

Why did I think those are SSD-related issues? Because if I install Qubes 4.0.4 or 4.1 on a conventional spinning hard drive using exactly the same settings, none of the mentioned issues ever happened. Once the font size and DPI settings were changed, I never touch them again, and yet, about 50% of starts failed to initialize the windowing system with user’s settings.
I think I am facing sync issues here because everything happens so fast at startup, thanks to the SSD.

I can exclude hardware error in my system: Memory chips have been thoroughly tested many times without error. Two SSD’s were used in testing and none of them reports any error whatsoever.

Is anyone out there having the same issues as described? How can I fix them?


Are there any error messages?

Qubes wont start, if their corresponding netvm don’t start.
So if sys-net fails to start, sys-firewall and sys-whonix wont start.

sys-net can (depending on your settings) hold hardware. If those are not present, it will fail to start. What i experienced a few days before was it failing when i disabled wifi in the bios, as the device was missing.

Are there any error notifications?

Try to see if there is something that seems like an error in a dom0 root shell journalctl -xe or in the xen log at /var/log/xen/console/hypervisor.log or in dmesg.

I really doubt, that there is something wrong with the speed of your SSD. Maybe your cable is not inserted correctly, or it is just faulty.

Maybe the SSD is faulty. In this case you can check this with badblocks (after you created a backup).

First i would look for error messages in the appropriate logs tho.