Failed to Install Fedora-33-minimal Template (unexpected EOF in archive)


I have some problem installing fedora-33-minimal. This is the output from the dom0 terminal after installing fedora-33-minimal:
install fedora-33-minimal.log (6.8 KB)

After the installation the fedora-33-minimal Template VM hasn’t created, at least i haven’t seen in Qubes Manager.

And tis is the output from the dom0 terminal after tried to delete the Template VM:
uninstall fedora-33-minimal.log (2.2 KB)

Can anyone help me out what is the problem?

Thanks any help!

Moved this into a topic of its own as it seemed to be on a different issue than where it was originally posted. I’ve also remove the pastebin link and replaced it with logs uploaded to the forum. You can do this in the future just by dragging and dropping a .log file onto the forum post editor.

1 Like

Today i tried to install Fedora-33-minimal again. But i’m unable to install it. This is what i get now if i try it:
install.fedora-33-minimal.log (1.5 KB)

Does anyone have a clue what is going on?

Something weird happened during the install, probably space issue? In all the cases, try:

sudo dnf remove qubes-template-fedora-33-minimal

and it fails:

sudo rpm -e --noscripts qubes-template-fedora-33-minimal.

If it was an answer to my problem. Nothing has changed.

remove_fedora-33-minimal.log (3.1 KB)

There was no problem with the command as i can see.

based on your log :

  1. try cleaning cache first.
  2. looks like your sys-firewall using fedora 33, i suggest you do reinstalling template / maybe create new domain from fedora 33 template, use that template for sys-firewall.
  3. then try to install fedora-33-minimal template.

hope that helps.

Thanks for the advices! Unfortunately they didn’t help…

Here’s what i did:

  1. I’ve removed cache: sudo qubes-dom0-update --clean
    sudo qubes-dom0-update --clean.log (651 Bytes)

  2. Reinstalled Fedora-33:
    sudo qubes-dom0-update --action=reinstall qubes-template-fedora-33

  3. Rebooted the machine, because why not

  4. In the meantime i’ve found this article, so when the PC booted up i gave it a try:
    sudo rpm -q qubes-template-fedora-33-minimal
    sudo rpm -e --noscripts qubes-template-fedora-33-minimal
    This ia the outputs for these commands:
    rpm_commands.log (1.5 KB)

  5. Fully updated Fedora-33

  6. Tried to install fedora-33-minimal again: sudo qubes-dom0-update qubes-template-fedora-33-minimal
    sudo qubes-dom0-update qubes-template-fedora-33-minimal.log (6.4 KB)
    So there is 2 outputs which are really confusing: ‘shutil.Error: Destination path ‘/var/lib/qubes/vm-templates/tmp-fedora-33-minimal/fedora-33-minimal’ already exists’ & ‘installed’

  7. Tried to remove fedora-33-minimal: sudo dnf remove fedora-33-minimal
    sudo dnf remove qubes-template-fedora-33-minimal.log (2.2 KB)

  8. Then i’ve tried it again from the beginning: delete cache, install minimal with the same results.

  9. I’ve even tried to remove the directory /var/lib/qubes/vm-templates/fedora-33-minimal but it didn’t help either.

I haven’t tried your other advise (cloning fedora-33 template and using it as sys-firewall) because i think it would be the same. Mainly i think so, because the path already exists error would be there too.

Now i’m stuck and i don’t really know what to do next. I think i’ve tried everything from the VM Troubleshooting docu.