External screens going blank at random - please help, going crazy :-(

Hi all!

I’m having a problem with my two 2k external monitors where they, at seemingly random times, will blink quickly on and off, and then after just a couple more seconds show me that they’re receiving any input on that source anymore. In order to hack a fix for this I’ve found two solutions though Googeling;

  1. Use xrandr to turn the displays off and on. This will however mess with all the open windows in i3.
  2. Use xrandr to shift the display position back and forth by one pixel. This will get the displays on again without messing with the windows.

Now - these are by no means a temporary fix. It has now happened 13 times the last 40 minutes and I’m going crazy. Following is a description of my setup:

Laptop: Lenovo ThinkPad T490s
Monitors: LG 27GL850-B, Philips E-line 275E1S
Dock: Lenovo ThinkPad Thunderbolt 3 Dock Gen 2
Qubes version: R4.0
xen_version: 4.8.5-23
Linux kernel: 4.19.147-1 5.6.16-1

Both monitors are connected to the dock using HDMI cables.

The dock is connected to the laptop using USB-C and into the “Lenovo port”, not the USB-C at the far back. If I connect to that other USB-C port, the laptop will not even boot but is stuck at the Lenovo splash screen where I can choose to enter BIOS etc.

Also; This setup worked perfectly with two HD monitors - troubles started after I switched to 2k.
Also; Plugging one of my 2k monitors directly to my laptop through HDMI works just fine.

I hope someone is able to help me here :slight_smile: Thank you all in advance

I’d say before, you should try to diagnose where the problems come from in the following order:

  1. problem in the cable - (not likely since it’s two) try plugging the cable into another device and seeing if it works

  2. problem with the dock - disconnect it from the dock and plug in one HDMI cable onto the computer directly.

  3. problem with i3 - try logging in with XFCE and seeing if it works


It took me a while here, but I’ve now tested all three suggestions:
1. problem in the cable - I’ve tested several cables, the issue persists
2. problem with the dock - If the monitors are connected directly to the laptop through HDMI, the problem is not present.
3. problem with i3 - I’ve tested with XFCE, the issue persists.

Thanks for helping out :slight_smile:

Then it seems it’s a problem with the dock. I don’t have much experience with troubleshooting this, but at least we now know where the problem might reside.

It could be a problem with some drivers or linux kernel modules. Given it’s a thinkpad, there might be lots of resources out there to debug hardware issues with the dock. So I’d suggest looking into that. Perhaps it’s something that has been fixed in a newer kernel than Qubes ships with?

Yes hopefully it’s isolated :slight_smile:

I’ve “Googled”, alot, to try and find others with a similar problem. And there are some examples ( here’s one: https://bugs.launchpad.net/ubuntu/+bug/1574617 ), but I haven’t yet been able to find a solution.
I’ve also tried upgrading the kernel from 4.19.147 to 5.6.16, but the problem still persists.

I’ve seen some mentions of updating the thunderbolt firmware, but I couldn’t figure out how to do this. What do you think about that? :slight_smile:

The issue you described sounds a lot like that myself and another user
had in

You’re on a laptop, so this may be unhelpful, but our solution was
dropping HDMI for DP. If you have the space USB-C or DP ports, give this
a go.

Unfortunately, changing the cables does not work, the problem still persist.
I also think the main difference here is that the problem only occurs when the monitors are connected to the dock, and the dock connected to the laptop. If I connect one of the monitors directly to the laptop there are no issues at all, even at 2k resolution.

But thank you for your time and suggestion!

1 Like

Possibly related. 4k monitor connected via mini-dp to HDMI adapter.

A couple of times a minute, the screen will turn on and off. This has happened after I reinstalled Qubes (R4). Same hardware worked perfectly well last week.

Also running i3. What other info should I post to take a shot at diagnosis?

Happened to me at some point. The reason was interference with other device laying around.

1 Like