External numeric keypad change keyboard language

Hello, since I have a little laptop without a numeric keyboard, which I use a lot, a coworker give me an old usb numerick keypad. Everything works fine, but when I turn on the tool, the keyboard mapping switch to the english one (which was the first default one) until system reboot :see_no_evil:
This happen despite the configuration in /etc/X11/xorg.conf.d/00-keyboard.conf remains the same, which actually is:

Section “InputClass”
Identifier “system-keyboard”
MatchIsKeyboard “on”
Option “XkbLayout” “latam”
Option “XkbModel” “deadtilde”

I was not able to find a specific language keypad setting :face_with_raised_eyebrow: anybody have idea of some soluion or workaround to this?

Thanks in advance!

I was able to solve this problem thanks to the usb qubes documentation which definitively one of the most accurate that I’ve found in linux distributions.
Aware of the risks, I connect the keypad to dom0 with
sudo qubesctl state.sls qvm.usb-keyboard
The language now remains the same also with the keypad on.

1 Like

Thanks for reporting back. This will be useful for users with the same issue. I’ve marked your post as the “solution”.

1 Like