Error Updating to Fedora 33: Failed to return clean data

I tried updating the fedora vm. I did that, and changed from fedora 32 to 33 in the default option. Tried to update and i get this:

Updating fedora-33

Error on updating fedora-33: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’, ‘–targets=fedora-33’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’]’ returned non-zero exit status 20
fedora-33:
----------
_error:
Failed to return clean data
retcode:
1
stderr:
Traceback (most recent call last):
File “/var/tmp/.root_dd8a91_salt/salt-call”, line 27, in
salt_call()
File “/var/tmp/.root_dd8a91_salt/pyall/salt/scripts.py”, line 445, in salt_call
client.run()
File “/var/tmp/.root_dd8a91_salt/pyall/salt/cli/call.py”, line 48, in run
caller = salt.cli.caller.Caller.factory(self.config)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/cli/caller.py”, line 64, in factory
return ZeroMQCaller(opts, **kwargs)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/cli/caller.py”, line 329, in init
super(ZeroMQCaller, self).init(opts)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/cli/caller.py”, line 89, in init
self.minion = salt.minion.SMinion(opts)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/minion.py”, line 912, in init
opts[“grains”] = salt.loader.grains(opts)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/loader.py”, line 825, in grains
ret = funcskey
File “/var/tmp/.root_dd8a91_salt/pyall/salt/grains/core.py”, line 2384, in ip_fqdn
ret[“ipv6”] = salt.utils.network.ip_addrs6(include_loopback=True)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/utils/network.py”, line 1353, in ip_addrs6
return _ip_addrs(interface, include_loopback, interface_data, “inet6”)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/utils/network.py”, line 1333, in _ip_addrs
ret.add(addr)
File “/usr/lib64/python3.9/ipaddress.py”, line 1925, in hash
return hash((self._ip, self._scope_id))
AttributeError: _scope_id
stdout:

What do i do? I have a vpn, but that’s not the issue is it?
How should i update when a new fedora is released? It would be easier if you used debian as the templateVM’s instead of fedora right? Less updates…
If i have installed a bunch of stuff in an templateVM and fedora version, do i need to install those again with every new fedora release? I’m not knowledgeable when it comes to this… Thanks in advance.

Should i delete fedora 32 and also change all settings in the template manager from fedora 32 to 33?
Shutdown VM’s and change them? How can i remove the error and update fedora?
I think i had this answer earllier, but can’t find it now… On how to update fedora versions. I did it wrong…
It can be updated with one command right? I just gpt the error that fedora 32 has ended, and i used:

$ sudo qubes-dom0-update qubes-template-fedora-33

Then i changed the default template from 32 to 33. Why can’t i update and what did i do wrong this time? Thanks

update: I did it right… I can update now… I did not change all settings earlier. But next time with 34 i want to clone and update. Because now i need to install new stuff again on this fedora version… Debian does have their versions longer, so in my opinion it would be smarter to use debian as templateVMs by default…

You may missing announcement,

Important: If you wish to use the Qubes Update widget to update a Fedora 33 template, you must first switch the default-mgmt-dvm qube to a Fedora 33 template. (Alternatively, you can create a separate management DisposableVM Template based on a Fedora 33 template for the purpose of updating Fedora 33 templates.) This does not affect updating internally using dnf .

It works now… I just need to install some programs again though… So i can use them in my Domain VM’s. Next time i need to update i’m gonna ask on here or read up. I will clone that one instead… And update. If possible. Because people don’t install new browsers and stuff every time they want to update qubes or fedora on here…
But can i update to fedora 34 next time with the qubes update widget ontop you mean? One click away? That would be great! If i had swiched that setting earlier it might have worked with the widget then… If that’s what you’re saying. :slight_smile: Thanks

yes on top, yellow orange one like sun

next time, install fedora 34 template first then change every fedora 33 based template to 34, it’s recommended by qubes team.

alternatively you can update using dnf update.

Alright… I need to install new programs in the v34 next time, and that’s a waste if time… Better to use dnf update if i can update a version that way next time. :slight_smile:
Thanks